Anordnen der Navileiste klappt nicht... [Bitte Helfen]

Dieses Thema im Forum "Webdesign" wurde erstellt von MolchMaster, 25. März 2006 .

Schlagworte:
Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 25. März 2006
    Zuletzt von einem Moderator bearbeitet: 14. April 2017
    So, ich bastle schon den ganzen Tag an einer neuen seite, und als ich jetzt bei der navileiste bin, funkt das einbauen der einzelnen Bilder nicht.

    So soll es aussehen:

    [IMG[/IMG]

    und so sieht es leider aus:

    {bild-down: https://xup.in/dl,20768942/}

    {img-src: }

    Hier der Code, wie ich die Bilder eingebunden habe:

    Code:
    <img src="Header.gif" width="800" height="130" align="absbottom"></img><br>
    
    [Kommentar]//Header-Bild (in Blau)\\[/Kommentar]
    
    <img src="Line_1.gif" width="100" height="25" align="absmiddle"></img>
    <img src="Line_2.gif" width="100" height="25" align="absmiddle"></img>
    <img src="Line_3.gif" width="100" height="25" align="absmiddle"></img>
    <img src="Line_4.gif" width="100" height="25" align="absmiddle"></img>
    <img src="Line_5.gif" width="100" height="25" align="absmiddle"></img>
    <img src="Line_6.gif" width="100" height="25" align="absmiddle"></img>
    <img src="Line_7.gif" width="100" height="25" align="absmiddle"></img>
    <img src="Line_8.gif" width="100" height="25" align="absmiddle"></img>
    
    ich habe auch schon diverse aligment (align) versucht, aber es geht nicht (auch nicht, wenn ich die weglasse). Ich will ja nur, dass die Lücken zwischen den einzelnen Buttons verschwinden.

    10er für jede Hilfe!!!

    THX
     

  2. Anzeige
    Dealz: stark reduzierte Angebote finden.
  3. #2 25. März 2006
    packt die navi leiste in eine tabelle.alle einzelnen bilder ordnen sich dem entsprechend nebeneinander,ohne ein lücke zu lassen.
     
  4. #3 25. März 2006
    un dvergiss nicht bei der tabelle dann boarder auf 0 zu stellen ansonsten hast du das gleiche problem wieder

    dein banner und deine buttons mussen in der selben spalte sein!
     
  5. #4 25. März 2006
    Zuletzt von einem Moderator bearbeitet: 14. April 2017
    Ok, danke, aber jetzt ist da so ein kleiner Spalt zwischen der Navileiste und dem Text:

    {bild-down: https://xup.in/dl,20768942/}

    {img-src: }

    Der Code:

    Code:
    *edit*
    
     
  6. #5 25. März 2006
    tableborder=0

    wenn ich jetzt richtig liege ^^....
    code nicht wirklich aber müsste so sein....
     
  7. #6 25. März 2006
    Zuletzt von einem Moderator bearbeitet: 14. April 2017
    Bringt nix...
    :baby:

    außerdem habe ich ja schon border="0" bei der tabelle.

    währe nett, wenn mir doch noch jemand helfen könnte... 8)


    //EDIT:

    Verdammt! Ich habe die ganzen Buttons nun zu Hyperlinks gemacht. Schaut euch das mal an:

    {bild-down: https://xup.in/dl,20768942/}

    {img-src: }

    Hier der Code, wie er jetzt ist:

    Code:
    *edit*
    
    Währe echt nett, wenn sich mal jemand drumm kümmern könnte... :D
     
  8. #7 25. März 2006
    Ok, ich denke, dass es sehr gut an dem <div> liegen kann.

    bei mir sieht es so aus und klappt wunderbar

    Code:
    <tr>
     <td><img src="images/Slice_4.gif" alt="Navleiste links" height="40" width="200"></td>
     <td class="navlinks">
     <Table cellpadding="0" cellspacing="0" align="center" border="0">
     <tr>
     <td><a href="contest2.html"><img src="images/Slice_5.gif" alt="sitelink1" border="0"></a></td>
     <td><a href="contest2.html"><img src="images/Slice_6.gif" alt="sitelink2" border="0"></a></td>
     <td><a href="contest2.html"><img src="images/Slice_7.gif" alt="sitelink3" border="0"></a></td>
     <td><a href="contest2.html"><img src="images/Slice_8.gif" alt="sitelink4" border="0"></a></td>
     <td><a href="contest2.html"><img src="images/Slice_9.gif" alt="sitelink5" border="0"></a></td>
     </tr>
     </table>
     </td>
    
     <td><img src="images/Slice_10.gif" alt="Navleiste links" height="40" width="200"></td>
    </tr>
    
    Ausserdem solltest du bei dir darauf achten, dass die die Tags in der richtigen Reihenfolge schließt.
    Beispil:
    Code:
    FLSCH:
    <a><img></a></img>
    
    RICHTIG:
    </a><img></img></a>
    

    Wenn du schon darauf achtest, XHTML conform zu programmieren, solltest du dich auch an die grundlagen von HTML/XHMTL halten ;)

    Ein weiteres problem dass du bei den Links hast, ist dass du die Rahmen um die Bilder (sind ja verweise ) nicht deaktiviert hast.
    Dies kann man entweder in css machen, oder direkt in HTML, indem du in den img-tag noch "border=0" schreibst.

    Ansonsten kann ichd ir eigentlich nur den Tipp mit dem div-element geben. (meines wissens erzwingen nämlich sowohl das Table, als auch das div element eine neue Zeile, was bei deinem Beispiel dann also zu einem Leren Feld führt, kann mich da aber auch irren..
    du kannst bei der Tabelle jedoch auch direkt die Ausrichtung einstellen mit "align=center".

    Ich hoffe, ich konnte dir helfen.
     
  9. #8 25. März 2006
    Danke, Codas! Jetzt funktioniert es wunderbar. :D 10er is an alle raus!
    ;)
     

  10. Videos zum Thema
Die Seite wird geladen...
Similar Threads - Anordnen Navileiste klappt
  1. Antworten:
    4
    Aufrufe:
    921
  2. Antworten:
    4
    Aufrufe:
    977
  3. Antworten:
    1
    Aufrufe:
    345
  4. [Windows 7] Taskbar icons anordnen

    -eCCo- , 18. Dezember 2009 , im Forum: Windows
    Antworten:
    4
    Aufrufe:
    889
  5. Antworten:
    8
    Aufrufe:
    2.344