Apache2 | root-pfad

Dieses Thema im Forum "Linux & BSD" wurde erstellt von myth2806, 16. März 2006 .

Schlagworte:
Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 16. März 2006
    Moin leutz

    ich würde gerne einen kleinen webserver aufsetzten unter debian mit apache2.
    jetzt habe ich apache installiert und es läuft auch aber ich habe ein problem.
    der ordner in die die webseiten eigendlich reinsollen ist "/var/www/" ... leider
    ist das standartverzeichniss "/var/www/apache2-default".
    dort ist ein kleiner inhalt mit ner testseite von apache. ich kann diese siete zwar löschen
    und meine reintuhen das funtzten dann auch aber dass is ja schon irgendwie shice.

    in den configs hab ich auch schon gesucht aber nichts gefunden -.-

    wo kann man das einstellen?

    greez myth
     

  2. Anzeige
  3. #2 16. März 2006
    Schau dir mal das home-Verzeichniss vom Benutzer www-data an. Zur not symlink.
     
  4. #3 16. März 2006
    wenn du meinst das dieser benutzer unter /home/www-data gemappt sein sollte dann gibt es ihn bei mir nicht.... und was ist symlink??

    greez myth
     
  5. #4 16. März 2006
    was du suchst ist die apache config.

    zu finden unter /etc/apache2/httpd.conf (vor httpd.conf kann noch ein /conf/ stehen)

    darin findest du irgendwo DocumentRoot=/pfad
    das änderst du einfach auf den gewünschten pfad, richtigerweise also /srv/www/

    ein symlink ist quasi ein ordner, wo du, wenn du ihn betrittst in einem anderen ordner landest, auf den der symlink zeigt
     
  6. #5 16. März 2006
    leider befindet sich in dieser configurationsfile nur das hier :

    Code:
    # This is here for backwards compatability reasons and to support
    # installing 3rd party modules directly via apxs2, rather than
    # through the /etc/apache2/mods-{available,enabled} mechanism.
    #
    #LoadModule mod_placeholder /usr/lib/apache2/modules/mod_placeholder.so
    
    ich denke ich werde dann auf einen symlink zurückgreifen.. aber wie erstellt man so einen?

    greez myth
     
  7. #6 16. März 2006
    du kannst die documentroot option dort einfach reinschreiben. ich guck kurz mal die genaue schreibweise nach...


    //:

    DocumentRoot /srv/www/htdocs

    steht bei mir. setz dort einfach den von dir gewünschten pfad rein...
     
  8. #7 16. März 2006
    Nein sein Homeverzeichniss ist das Rootverzeichniss vom Apachen, schau mal mit KUser nach. Aber das mir der httpd.conf sollte genauso funktionieren.
    http://de.wikipedia.org/wiki/Symbolischer_Link sollte man kennen.
     
  9. #8 16. März 2006
    schau mal unter /etc/apache2/sides-enabled/default

    dort kannst du dann die refered seite einfach ausmakieren mit #
    u. bei document root od. so .. deinen pfad bestimmen..

    achtung.. weiß jetzt nicht die 100%tige schreibweise.. is jetzt einfach ma ausm kopf
     
  10. #9 17. März 2006
    moin leutz!!

    ich bins noch mal also ich bin jetzt auf den post von cracydoq eingegangen und habe die datei editiert.

    vorher stand das hier in der datei:

    Code:
     ServerAdmin webmaster@localhost
    
     DocumentRoot /var/www/
     <Directory />
     Options FollowSymLinks
     AllowOverride None
     </Directory>
     <Directory /var/www/>
     Options Indexes FollowSymLinks MultiViews
     AllowOverride None
     Order allow,deny
     allow from all
     # This directive allows us to have apache2's default start page
     # in /apache2-default/, but still have / go to the right place
     RedirectMatch ^/$ /apache2-default/
     </Directoy>
    
    
    ich habe diese fetten zeilen so editiert:

    Code:
     ServerAdmin webmaster@localhost
    
     DocumentRoot /var/www/
     <Directory />
     Options FollowSymLinks
     AllowOverride None
     </Directory>
     <Directory /var/www/>
     Options Indexes FollowSymLinks MultiViews
     AllowOverride None
     Order allow,deny
     allow from all
     # This directive allows us to have apache2's default start page
     # in /apache2-default/, but still have / go to the right place
     # RedirectMatch ^/$ /apache2-default/
     </Directoy>
    
    leider funktioniert es immer noch nicht
    was muss ich ändern?

    greez myth
     
  11. #10 17. März 2006
    Hm... Habs bei mir mal nachgeguckt und so wie es oben beschrieben wurde mit dem "/etc/apache2/sites-enabled/000-default" hats wunderbar gefunzt 8)

    Mal ne andere Frage ?(

    Haste vielleicht ein anderes Betriebssystem, wo die Config/das Verzeichnis anders ist ?( (hab Debian)
     
  12. #11 17. März 2006
    Code:
     
    NameVirtualHost *:80
    <VirtualHost *:80>
    ServerAdmin webmaster@localhost
    
     DocumentRoot /var/www/
     <Directory />
     Options FollowSymLinks
     AllowOverride None
     </Directory>
     <Directory /var/www/>
     Options Indexes FollowSymLinks MultiViews
     AllowOverride None
     Order allow,deny
     allow from all
     # This directive allows us to have apache2's default start page
     # in /apache2-default/, but still have / go to the right place
     # RedirectMatch ^/$ /apache2-default/
     </Directoy>
    </VirtualHost>
    
    So müsste es Richtig sein!
    Deine Homepage musst du halt nun in das Verzeichnis /var/www/ kopieren!

    ps: Du musst Apache2 natürlich danach neustarten damit die Änderungen übernommen werden!! Das geht dann mit dem Befehl "/etc/init.d/apache2 restart"
     
  13. #12 17. März 2006
    thx cracydog!!

    jetzt funtzt alles :]
    habt alle mal ne 10

    greez myth

    *closed*
     

  14. Videos zum Thema
Die Seite wird geladen...
Similar Threads - Apache2 root pfad
  1. Antworten:
    12
    Aufrufe:
    1.647
  2. Antworten:
    6
    Aufrufe:
    1.245
  3. Antworten:
    12
    Aufrufe:
    1.446
  4. Antworten:
    4
    Aufrufe:
    532
  5. Antworten:
    2
    Aufrufe:
    1.745