Crossover+Server?

Dieses Thema im Forum "Gamer Support" wurde erstellt von Andi85, 11. Januar 2006 .

Schlagworte:
Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 11. Januar 2006
    Hallo alle zusammen

    Ich hab da folgendes Problem: Ich hab meine 2PCs mit nem Crossover Verbunden und alles Funktioniert einwandfrei(Internet, Rüberziehen von Daten etc.) doch mein Problem ist, das wenn ich in einem Spiel(zB Cs:source, Tony Hawks Underground 2, WoW) einen Server erstelle, dann kann ihn keiner sehen bzw joinen. Ich selbst sehe ihn auch nicht. :( Kann mir jemand helfen? 10er an alle die mir weiterhelfen können ;)

    Andi
     

  2. Anzeige
  3. #2 11. Januar 2006
    Mh...komische Sache, sollte eigentlich funktionieren. Probiermal offline zu gehen und dann den Server zu erstellen. Villeicht siehst du ihn dann. ?(
     
  4. #3 11. Januar 2006
    Das ist es ja im LAN kann ich ihn sehen aber im Internet nicht :?
     
  5. #4 11. Januar 2006
    Achsooo!
    Mh.....ne frage nach welcher IP suchst du im "Internet"? Wenn du nach dem Server suchst?
    Ich weiß ja nicht genau wie gut du dich auskennst mit IPs in Netzwerken und im Internet. Aber du hast eine IP von deinem Internet-Provider, und wenn du über CrossOver verbindest hast du für die anderen Rechner im LAN nicht die IP von deinem Provider sondern eine andere, kA was du da eingestellt hast bei IP adressen.

    Wenn du ihn im Internet suchst dann musst du die IP nehmen die du von deinem Provider bekommst. Deine IP erfährst du hier: www.wasistmeineip.de

    PS: Sorry wenn du das vorher schon wusstest, aber ich weiß nunmal nicht wie gut du dich auskennst ;)

    /edit: Mh...es könnte aber auch sein, dass deine Firewall die Ports blockt, im LAN nicht aber villeicht im Internet. Betroffen wären speziell für CS:S denke ich mal folgende Ports: 27005, 27010, 27015
     
  6. #5 13. Januar 2006
    Na ich erstelle einfach einen Internet server und auch wenn ich versuche über IP zu joinen klappts nicht(zb bei cs in der Konsole 'connect <IP>'
    Komischerweise sind alle Ports freigeschaltet und auf dem PC mit Internetanschluss können Leute auf meinen WoW-Server joinen aber wenn ich ihn auf meinem anderen PC anschliesse können sies nicht. Ich vermute mal es ist irgendwas im Windows falsch konfiguriert aber ich find net raus was :(

    Naja 10er hast du trotzdem ;) danke für die mühe
     
  7. #6 13. Januar 2006
    Ääähhh... Moment mal... für Doofe bitte :)
    Du hast PC A und PC B. PC A ist mitm Internet verbunden, PC B geht über _________ (ausfüllen) ins Netz. Auf PC B willst du einen Server aufmachen, aber der Server ist weder online noch im LAN sichtbar. Soweit richtig? Wie machst du z.B. bei CS den Server auf?
     
  8. #7 14. Januar 2006
    Ich hoffe, diese Möglichkeit wird nicht durch einen anderen oben genannten Post ausgemerzt, aber ich glaube es so verstanden zu haben:
    Du hast 2 Pcs mit einem Crossover verbunden - kommst ins Internet mit beiden, kannst Daten vom Einen zum Anderen transferieren...
    Wenn du aber einen Server (Internet) eröffnest, können alle (andere Internet-User) auf den Server connecten, aber du mit deinem 2.Pc nicht. Solltest du die IP mit der du versuchtest zu connecten (speziell in cs) von http://www.whatismyip.com etc. haben, kann ich dir das Problem schnell erklären.
    Du eröffnest einen Internet Server - du suchst nach Internetservern mit dem 2.Pc... findest aber natürlich nichts, weil du über LAN verbunden bist.
    Um die interne IP Adresse herauszufinden (solltest du den Parameter auf "IP Adresse automatisch beziehen" gesetzt haben, sonst natürlich einfach ablesen) öffnest du die Eingabeaufforderung und gibst "ipconfig" ein (WinXP). Dort steht dann deine interne IPAdresse - mit dieser kannst du dann von deinem "Nicht-Server"Pc auf den "Server"Pc connecten.

    Nochmals kurz zusammengefasst:

    2 Pcs über LAN - beide mit Internet - mit Pc 1 wird ein (Cs) InternetServer eröffnet (Parameter muss inGame "sv_lan 0" gesetzt sein, ansonsten können keine anderen InternetUser connecten) mit Pc 2 wird über LAN (mit der internen IP Adresse von Pc 1!) connectet.
    Alle Anderen InetUser müssen mit der externen IP von Pc 1 connecten!

    Ich hoffe ich konnte helfen und habe das Problem weitgehend gelöst.

    mfg
     
  9. #8 15. Januar 2006
    OK das könnte erklären warum ich meinen CS-Server nicht joinen kann(also sv_lan 1.Danke ;) ) Ich hab mal n Bild angehängt wie das ganze angeschlossen ist. Aber ich meine das keiner den server überhaupt sehen bzw joinen kann wenn ich den auf dem 2ten PC starte(also übers internet jedenfalls). wenn er über LAN läuft geht es einwandfrei

    Momentan läuft mein WoW-Server sehr gut auf meinem 1en PC. wenn ich ihn auf dem 2ten PC starte kann ich den nur über LAN joinen :(. CS geht auf dem 2 leider nicht... kann nicht testen ob CS auf dem 1en gehen würde( zu lahm) aber ich bin mir sicher das es klappen würde wenn schon der WOW server da funzt...


    Vielleicht hilfts dir ja: Auf PC1 finden sich 3 anschlüsse wenn ich ipconfig bei cmd eintippe: DFÜ-Verbindung, Modem und Netzwerkkarte
    Auf PC2 findet sich nur die Netzwerkkarte
     
  10. #9 16. Januar 2006
    hi

    Also das ist jetzt schwer zu sagen... mit WOW kenne ich mich überhaupt nicht aus... bei Cs kannst mich wohl fragen was du willst, aber wow...
    Also hättest du kein Modem, sondern einen Router wär das Ganze wohl kein Problem.
    Der Server (egal welches Game) sollte natürlich auf dem Pc1 (anschließend, an deine Karikatur [: ) geöffnet werden. Ein Internetserver der über 2 Pcs läuft wäre wohl auch relativ sinnfrei. Solltest du den Server immer auf Pc2 öffnen, versuche doch einfach mal die beiden Pcs zu tauschen, wenn einer zu schwach ist, den Server zu öffnen.

    Also DFÜ-Verbindung kann fast nicht sein, da du nach deinen Angaben ja keine direkte Verbindung zum Splitter hast, sondern über ein Modem verbunden bist... Modem und Netzwerkkarte ist womöglich normal...
    Was du auch noch probieren könntest: IP Adressen automatisch beziehen AN/AUS.
    Dass keinerlei Connection zum Server vom Internet hergestellt werden kann, liegt entweder daran, dass du die Ports nicht geöffnet hast (Firewall etc.) oder man kann den Server in HLSW (zB) sehen und connenten kann, und dann kommt eine Fehlermeldung, da "sv_lan 1" etc gesetzt ist: wie man sv_lan 1/0 irgendwie so einsetzt, dass beide drauf connecten können, weiss ich nicht. Aber warscheinlich sind irgendwelche Ports geschlossen.

    mfg
     
  11. #10 17. Januar 2006
    Naja das mit der DFÜ-Verbindung is so passiert: Ich hatte kein bock mehr mich immer mit AOL einzuwählen und hab dann das ganze so umgestellt das ich über DFÜ nur noch Name und PW eintippen muss um ins I-Net zu kommen. Ausserdem würde ohne diese Verbindung mein Internet auf dem anderen PC nicht gehen da AOL normalerweise keine Internetfreigabe in der Software unterstützt

    Wie auch immer ich wollte nur den WoW-Server zum laufen bringen und es ist jetz auch egal obs dann irgendwann mal beim 2ten PC geht. Aber könntest du mir das mit der Firewall nochmal erklären? Ich glaub nämlich auch das da irgendwo was nicht stimmt

    Hab mal euch allen 10er gegeben
     
  12. #11 17. Januar 2006
    Also da du ja wie in deinem Bild zu sehen ist, ein Modem hast, wirst wohl keine Routerfirewall haben. Solltest du eine FW als Software installiert haben, kann es sein, dass diese die Ports für andere User blockt, die auf deinen Csserver connecten wollen.

    Ich hätte noch eine Frage wegen Cs: wie hast du den Server geöffnet? Einfach Cs starten - New Game - sv_lan 0 - Go? Sollte das der Fall sein, müsstest du 2 versch. Versionen von Cs (bzw 2 versch. Keys) installiert haben - auf den beiden Pcs... Ansonsten musst du nen "Dedicated Server" aufmachen (nachzulesen bei Google =) ).. wenns der gleiche Key ist...

    mfg
     
  13. #12 17. Januar 2006
    Also da du ja keinen Router hast, fällt die Option mit der Routerfirewall weg.. Solltest du eine Softwarefw installiert haben, dann könnten vlt die Ports geblockt werden um drauf zu connecten...

    Außerdem: könntest du mal genau erklären, wie du den Csserver aufmachst?

    /edit: na toll, doublepost... gut, dass rr nicht langsam ist und man denkt, der post kam nich an..

    mfg
     
  14. #13 19. Januar 2006
    Ich hab norton 2005 aber alles deaktiviert.... CS server mach ich entweder mit dedicated oder einfach create aber beides geht auf PC 2 net... auf PC 1 hab ich nicht mal Steam drauf
     
  15. #14 21. Januar 2006
    mach mal folgendes. vom server zum client und vom client zum server pingen. wenn du keine antwort bekommst dann is die firewall an oder die win firewall. das blöde is du merkst das net weil du daten trotzdem tauschen kannst.


    peace
     
  16. #15 22. Januar 2006
    Sry check ich nich... wie kannst du wissen, ob du mit PC1 auf den Server von PC2 connecten kannst, wenn du gar kein cs auf pc1 hast?!

    wenn du nochmals detailreich darstellen könntest, was du genau schon alles gemacht hast, wärs wohl nicht schlecht
     
  17. #16 23. Januar 2006
    HI,

    mach am besten mal deine Firewall aus

    ich hatte das Problem auchmal.

    mfg.
     
  18. #17 25. Januar 2006
    Sry check ich nich... wie kannst du wissen, ob du mit PC1 auf den Server von PC2 connecten kannst, wenn du gar kein cs auf pc1 hast?!

    Na es ist eigentlich egal welches Spiel da läuft auf PC1 würds gehen und auf PC 2 net... Das selbe Problem ist bei Teamspeak: Wenn der Server auf PC1 läuft gehts und wenn er auf PC2 läuft kann keiner connecten hab auch schon mal Tony Hawks Pro skater 3 drauf gezockt und wieder das selbe: Auf PC1 können leute auf meinen server connecten wenn ichs aber auf PC2 mach dann gehts net

    Das mit dem Pingen probier ich heute noch(Bin grad in der Schule) und häng einfach mal ein screenie voon den verbindungen an die ich hab
     
  19. #18 25. Januar 2006
    also ich würd einfach mal sagen wenn du keinen router hast würde ich am pc mal die Firewall für eingehende verbindungen konfigern. Wenn du in dem jetztigen einstellungen joinen kannst dann stimmt alles und nur deine Rewerselookupzone funzt net. Wenn der Rechner der als Gateway dient wür dich mal gugen ob du nicht mal nen dns einstellst oder ob der überhaupt funzt denn wenn auf ip alles geht nur die namen nicht dann kann es nur daran liegen.

    Greetz
    Neo
     
  20. #19 25. Januar 2006
    Ehm, also:

    Du willst einen CS Server im NETZWERK machen richtig?

    So also, das müsste eigentlich auch ohne Firewall settings gehen, zumindest bei einem der beiden PC´s (Wenn nich beide Firewall ham)

    und sonst probier doch ma, n Internet-Server aufzumachen, und dann vom anderen rechner drauf connecten per Internet-Ip.

    Mit WoW:

    Mach mal die Prots frei bei Firewall:
    6112
    6881-6999

    und MACH DIE WINDOWS FIREWALL aus, kann sein das die noch an ist!!
     
  21. #20 25. Januar 2006
    Also hab hier mal meine Netzwerkverbindungen ''fotografiert''

    Wenn ihr mit Firewall das meint das auf dem Bild von PC 2 zu sehen ist(Rechts), das hab ich bei allen Verbindungen deaktiviert.

    sorry kannst du mir das bitte nochmal erklären? :) Kenn mich mit Netzwerken nicht sooo gut aus.


    @DerHaby: Wenn ichs richtig verstanden habe soll ich im internen netzwerk meine PCs anpingen, oder? naja bei beiden klappt es und es sind 128ms bei beiden(komisch das es so langsam ist oder ist es normal?!?!)
     
  22. #21 26. Januar 2006
    128ms sind nomal und reicht für eine gute verbindung.
    Hast du noch Service Pack2 auf den rechnern ??? denn dann musst du unter start->systemsteuerung-> Windows Firewall das ding mal ausschalten und nicht nur den hacken wie bei bild 2 :D.

    Nice try till next time
    Neo
     

  23. Videos zum Thema