Debian startet nimmer inx X

Dieses Thema im Forum "Linux & BSD" wurde erstellt von impf0s, 23. August 2005 .

  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 23. August 2005
    Ich habe jetz mit der ATI Treiber Installation (ati*.run-Datei) von der ATI HP den Treiber für meiner Radeon 9500 installiert.
    Danach habe ich fglrxconfig gestartet und die empfohlenen Werte (die dahinter in eckigen Klammern stehen) eingegeben.

    DOch nun wenn ich meinen PC starte und im GRUB debian boote, wird der Bildschirm nach dem Start von X ganz grün und der PC freezt ein.

    Mein Frage: WIE KANN ICH DAS WIEDER BESEITIGEN?
    und wie kann ich dann die Grafik richtig einrichten?!

    Vorher ging schon alles ohne Probleme :/

    nach dieser anleitung habe ich gearbeitet:
    http://www.debianforum.de/forum/viewtopic.php?t=51913
    Ich hab
    apt-get install "kernel-headers"
    apt-get install gcc (war schon installiert)
    dann chmod
    dann programm gestartet
    fenster von ati öffnet sich, treiber installiert

    fglrxconfig gestartet
    alle empfohlenen Sachen eingestellt
     

  2. Anzeige
  3. #2 23. August 2005
    mach mal 'man startx' und schau wie man debugmode anmacht. dann startest mit mit "startx" und dem nötigen parameter der debuginfos ausgibt. die pastest mal hier
     
  4. #3 23. August 2005
    achja hab ich vergessen, im normalmode komm ich nicht mehr in die konsole irgendwie, weil der startet immer automatisch "startx".
    ich kann nur in der recovery was machen und dort funktioniert startx z.b. ned :/

    EDIT:
    Ich hab es geschafft, ich hab mit einem älteren Kernel gebootet!
    Jetzt hab ich den neuesten testing-kernel installiert und noch mal fglrxconfig gestartet.
    da hab ich gesehn , dass er 1280x1024 als standard gewählt hat, das schafft mein tft nicht.

    jetzt funktioniert das booten wieder, aber ich will jetzt die alten kernels löschen und schaun ob jetzt der treiber läuft bzw. ob er die karte erkannt hat!

    da gibts ja befehle, aber ich find sie nicht...

    EDIT2:
    Code:
    martin@debian:~$ fglrxinfo
    display: :0.0 screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.3 Mesa 4.0.4
    martin@debian:~$
    
    das sagt mir aber ned viel aus :/

    EDIT3:
    Code:
    martin@debian:~$ glxinfo|grep rendering
    direct rendering: No
    
    sagt dass irgendwas nicht läuft... :/

    mfg impf0s
     
  5. #4 24. August 2005
    das direct rendering sagt aus dass die opengl unterstützung für deine grafikkarte nicht läuft. wenn du den grafikkartentreiber installierst musst du die kernel-headers bzw. sources und den tree parat haben, sonst wird da nix.

    mfg
     
  6. #5 25. August 2005

  7. Videos zum Thema
Die Seite wird geladen...
Similar Threads - Debian startet nimmer
  1. Antworten:
    3
    Aufrufe:
    681
  2. [Debian] Xorg startet nicht

    MasterJulian , 29. Dezember 2010 , im Forum: Linux & BSD
    Antworten:
    6
    Aufrufe:
    1.477
  3. Antworten:
    9
    Aufrufe:
    568
  4. debian startet nicht?!

    karl89 , 3. September 2005 , im Forum: Linux & BSD
    Antworten:
    0
    Aufrufe:
    424
  5. Antworten:
    2
    Aufrufe:
    720