mit ati Treibern unter suse linux

Dieses Thema im Forum "Linux & BSD" wurde erstellt von Duken, 1. September 2005 .

Schlagworte:
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 1. September 2005
    Hi ich hab ein problem mit dsen treibern
    1. ich kan die run datei net ausfueren weder in kernel noch als root
    2. die andere datei die man runterladen kan die xfree86 die hab ich installirt aber ich weis net warum ich jetyt nurnoch im savemode hochfahren kan
    kann mir bitte einer helfen
     

  2. Anzeige
  3. #2 1. September 2005
    also das 2te kann ich dir beantworten denk ich ;)
    du hast wahrscheinlich Xorg drauf und nich xfree68...
    versuchs auch gerade gescheit hinzubekommen meld mich wenn ich das prob gefunden hab.
     
  4. #3 1. September 2005
    danke
     
  5. #4 1. September 2005
    1. meld dich grafich als root an!
    2. lade dir diesen
    ATI Driver Installer https://support.ati.com/ics/support/default.asp?deptID=894&task=knowledge&folderID=27 Treiber für Linux x86 runter (oder 64_x86 fals 64er maschiene)
    3. geh in die konsole
    4. wächsele mit "cd /pfad/zur/run/" in das verzeichniss wo die run liegt!
    5. starte das setup mit ./ati-driver-installer-8.16.20-i386.run
    6. dann kommt eine setuprutine änlich die von windoof
    7. reeboot und dann müsste 3d laufen (zu testen mit "glxgears")

    hoffe das hilft dir bei mir wars genau so!
     
  6. #5 2. September 2005
    wen es so einfaach wehre hätte ich keine probleme
    geht leider net hab ich schon ausprobirt komt ne fehlermeldung : keine berechtigung sagt er wen ich mich als root in der konspole einloge warum weis ich nicht

    das is nochmal der ganze textabschitt:


    Duken@linux:~> su
    Password:
    linux:/home/Duken # ./ati-driver-installer-8.16.20-i386.run
    bash: ./ati-driver-installer-8.16.20-i386.run: Keine Berechtigung
    linux:/home/Duken #
     
  7. #6 2. September 2005
    erstens sagte ich grafich und 2. musst du die run noch ausfürbar machen und zwar so:

    su
    Password:
    chmod -x ati-driver-installer-8.16.20-i386.run // kann auch +x gewesen sein weiss ich jetzt ned mehr
    dann kannst mit
    ./ati-driver-installer-8.16.20-i386.run // fals die datei nicht aufinbar ist schreib mal ati- und drücke dann die [tab] taste dann müsste der name richtig angezeigt werde

    den krams installen aber besser du machsts grafich als root....is einfacher
     
  8. #7 2. September 2005
    ich habs ausprobirt geht leider nicht so wie du es geschirben hast ich habs auch mit + versucht geht auch net er sagt immernoch no such file or directory
     
  9. #8 3. September 2005
    Das muss bei dir gehen!

    hier mal wie ich es gemacht habe:
    Chmod:
    suse@linux:~> su
    Password:
    linux:/home/suse # cd /srv/ftp/Linux/other
    linux:/srv/ftp/Linux/other # chmod +x ati // jetzt tab drücken

    jetzt müsste dort automatich

    linux:/srv/ftp/Linux/other # chmod +x ati-driver-installer-8.16.20-i386.run

    stehen einmal enter und chmod ist gesetzt




    Installieren:
    suse@linux:~> su
    Password:
    linux:/home/suse # cd /srv/ftp/Linux/other //paf zur datei
    linux:/srv/ftp/Linux/other # ./ati // jetzt [Tab] drücken

    jetzt müsste automatich da stehen (solange keine anderen datein mit ati am anfang im ordner sind)

    linux:/srv/ftp/Linux/other # ./ati-driver-installer-8.16.20-i386.run

    dann enter und los gehts




    PS. die // sind immer Komentare von mir! also nict hinschreiben

    PPS. was für ne Suse version hast du denn? wenn 9.1 und auf neuesten kernel ugedatet dann kann ich dir meine erstellte *.rpm geben.?

    hier meine mit dem installer erstellte rpm (ich weiss nicht ob sie bei dir geht, ist dein risiko!!)
    http://filecache.de/84908661/
     
  10. #9 4. September 2005
    Eine andere Alternative wäre
    Code:
    source file
    
    , ohne Berechtigungen setzen zu müssen.

    Mit deinem ATI-Driver Problem kann ich dir nicht helfen. Ich kann dir bloß sagen (evt. trösten :)), dass du nicht der Einzigste mit solchen Problemen bist. Ich kenne viele Leute, die sich schon stundenlang darüber aufgeregt haben. Mittels Google findest du vielleicht die Lösung.

    Ich habe mir deswegen extra vor einem Jahr eine nvidia-Karte mit dem Hintergedanke, dass die Treiber für den Kernel bei nvidia einfach besser sind, als die von ATI, zugelegt. Ich hatte mit den Grafik-Treibern auch noch nie Probleme hier. 8)
     
  11. #10 4. September 2005
    ich würd mir ja eine kaufen hab aber leider kein geld
     
  12. #11 5. September 2005
    Duken, sonst würde er sein Problem hier nicht schreiben.

    Edit: Okay.. war sinnlos, seh ich grade.
     

  13. Videos zum Thema
Die Seite wird geladen...