Open Suse 10.2 WLAN problem

Dieses Thema im Forum "Linux & BSD" wurde erstellt von Annonymous01503, 22. April 2007 .

Schlagworte:
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 22. April 2007
    Hallo liebe RR Community,

    Und zwar bin ich von XP zu Linux umgestiegen.
    Ich hab das problem das ich Tage lang nen ( Fritz! WLAN USB STICK 128 ) zu installieren versuche.
    Habe allerdings auch schon sämtliche probleme von diesem Stick unter Linux gehört.
    Es scheint das mit der installation geklappt hatt, nur der versuch ins Internet zu kommen leider vergebens.
    Also er hatt nichtmal nen Signal zum Router(192.168.2.1), hab auch in der Linux Konsole alles versucht.
    Ich habe sämtliche Turtorials,Manual,Google brobiert aber nichts hatt wirklich geholfen.
    Weder mit diesem normalen Linux Treiber von der AVM Homepage,noch diesen Ndiswrapper gehts nicht.
    Ich bin echt am durchdrehen mit diesem Linux,kurz davor es wieder runterzuschmeißen!

    könnt ihr mir helfen wäre echt für jede Antwort äuserst dankbar!

    Gruß Annonymous01503

    Mein Rechner:
    K7VM2 Asrock
    40gb
    512mb
     

  2. Anzeige
    Dealz: stark reduzierte Angebote finden.
  3. #2 22. April 2007
  4. #3 22. April 2007
    AW: Open Suse 10.2 WLAN problem

    hatt leider nicht geholfen


    Linux Netwerkonfiguration:
    IP,SUBNETT,DNS,GATEWAY alles richtig.
    Und ich immer noch nicht ins Internet bzw router connecten kann.

    Was ich noch hinzufügen muss:
    Hab am anfang den Linux treiber für den AVM Stick installiert
    danach den ndiswrapper mit den Windows treiber(inf file).

    irgendwie glaub ich so langsam das es am treiber liegt.
     
  5. #4 22. April 2007
    AW: Open Suse 10.2 WLAN problem

    Ist bei dem Router mit dem du dich verbinden willst eine Verschlüsselung drin? Hatte selber mal das Problem dass ich mich mit keinem verschlüsselten WLAN unter Linux verbinden konnte.

    Wenn du eine Verschlüsselung drin hast dann schalt die einfach mal aus und schau dann ob du deinen Router anpingen kannst bzw ob das Inet funktioniert.

    Was sagt denn der Kwifimanager? Zeigt er eine bestehende Verbindung an?
     
  6. #5 22. April 2007
    AW: Open Suse 10.2 WLAN problem

    benutze auch suse 10.2 und ob ein wlan verschlüsselt oder nicht verschlüsselt ist, ist bei mir egal, denn ich krieg trotzdem die verbindung.
    ich hab das was ich gemacht habe mal zusammen gefasst., vielleicht hilft es dir ja :)

    Download the Windows WLAN-card driver for your WLAN-Card
    - Login with ROOT
    - ndiswrapper -i /windows/c/SwSetup/WLAN/bcmwl5a.inf
    - Check, if the ndiswrapper has installed the driver:
    - ndiswrapper -l
    Installed drivers:
    bcmwl5a driver installed, hardware present

    - If there is a "fuzzy driver" or "hardware not present", you probably have a bad driver, and it doesn't work. Maybe you want to retry with
    a different, or you have to give up. Linksys, Belkin, and occasionally D-Link have a different chip on the card, generate problems and then a "fuzzy" driver is the result. Wiki of ndiswrapper project might help you then.

    - Note: If you downloaded the driver off the internet and can't get it to work, try to use the drivers on the CD that came with the wireless
    device(if one came at all).

    - Otherwise:
    Network configuration

    * Start YaST's network configuration: Network Devices → Network Card
    * Choose: "User controlled with Network Manager" and then "Next"
    * Choose: "Add" button in lower half
    * Choose:
    o Device Type: "Wireless"
    o Configuration Name: "0" (or whatever :))
    o Hardware Configuration Name: "static-0"
    o Module Name: "ndiswrapper"
    o Options: "" (keep empty)
    o Do not select "PCMCIA" nor "USB"
    o ... and finally "Next"
    * On next screen select DHCP in "Hostname and Name Server" and in "Advanced → DHCP Options", then click "Next"
    * In "Wireless Network Card Configuration"-window choose (= keep the defaults):
    o Operation Mode: "Managed"
    o Network Name (ESSID): "" (keep empty)
    o Authentication Mode: "Open"
    o Input Type: "Passphrase"
    o Encryption Key: "" (keep empty)
    o .. . and finally "Next"
    * the kwallet manager might open -- give him your password and ignore this opening (it doesn't do anything)
    * ignore the warning that "Encryption is doing on own risk"
    * back in "Netwark Card Configuration Overview" choose "Next"

    Your card is configured.

    - Reboot your system
     
  7. #6 22. April 2007
    AW: Open Suse 10.2 WLAN problem

    Ja ich hab ne WEP verschlüsselung drinnen.
    Die beim Xp aber einwandfrei funktionierte zum router.
    Der Kiwimanager zeigt keine verbindung an(kein Signal
     
  8. #7 23. April 2007
    AW: Open Suse 10.2 WLAN problem

    bin immer noch nicht weitergekommen
    Danke trotzdem
     
  9. #8 23. April 2007
    AW: Open Suse 10.2 WLAN problem

    Hi

    Also ich kenne jetzt keine direkte Lösung unter SuSE, aber du könntest doch immer noch versuchen Ubuntu 7.04 herunterzuladen:

    Download Ubuntu Desktop | Ubuntu


    In dieser neuen Version gibts jetzt auch den NetworkManager von RedHat und mit dem funktioniert das ganze verschlüsselungszeug eigentlich ganz gut. Er fordert einem dann auf das Passwort bzw. den Schlüssel einzugeben, sobald er das Netzwerk gefunden hat.

    Kannst du uns vielleicht einmal die Ausgabe von iwlist scanning geben?

    Mfg Bl0bb
     
  10. #9 23. April 2007
    AW: Open Suse 10.2 WLAN problem

    so hier mal ausfühlriches übers System ohne diesen ndiswrapper:
    mit dem aktuellen Linux treiber von der AVM Homepage:
    Weil es ja mit Ndiswrapper sowieso nicht funzt:
    IP vom Router ist 192.168.2.1

    BOOTPROTO='static'
    BROADCAST=''
    ETHTOOL_OPTIONS=''
    IPADDR='192.168.2.5'
    MTU=''
    NAME='WLAN'
    NETMASK='255.255.255.0'
    NETWORK=''
    REMOTE_IPADDR=''
    STARTMODE='auto'
    USERCONTROL='no'
    WIRELESS_AP=''
    WIRELESS_AUTH_MODE='open'
    WIRELESS_BITRATE='auto'
    WIRELESS_CA_CERT=''
    WIRELESS_CHANNEL=''
    WIRELESS_CLIENT_CERT=''
    WIRELESS_CLIENT_KEY=''
    WIRELESS_CLIENT_KEY_PASSWORD=''
    WIRELESS_DEFAULT_KEY='0'
    WIRELESS_EAP_AUTH=''
    WIRELESS_EAP_MODE=''
    WIRELESS_ESSID='WLAN'
    WIRELESS_FREQUENCY=''
    WIRELESS_KEY=''
    WIRELESS_KEY_0='A2B456C89E23E56F891G34J678'
    WIRELESS_KEY_1=''
    WIRELESS_KEY_2=''
    WIRELESS_KEY_3=''
    WIRELESS_KEY_LENGTH='128'
    WIRELESS_MODE='Managed'
    WIRELESS_NICK=''
    WIRELESS_NWID=''
    WIRELESS_PEAP_VERSION=''
    WIRELESS_POWER='yes'
    WIRELESS_WPA_ANONID=''
    WIRELESS_WPA_IDENTITY=''
    WIRELESS_WPA_PASSWORD=''
    WIRELESS_WPA_PSK=''
    _nm_name='static-0'


    gestarte prozesse:
    PID TTY TIME CMD
    1 ? 00:00:01 init
    2 ? 00:00:00 migration/0
    3 ? 00:00:00 ksoftirqd/0
    4 ? 00:00:00 events/0
    5 ? 00:00:00 khelper
    6 ? 00:00:00 kthread
    9 ? 00:00:00 kblockd/0
    10 ? 00:00:00 kacpid
    79 ? 00:00:00 cqueue/0
    80 ? 00:00:00 kseriod
    122 ? 00:00:00 pdflush
    123 ? 00:00:00 pdflush
    124 ? 00:00:00 kswapd0
    125 ? 00:00:00 aio/0
    366 ? 00:00:00 kpsmoused
    774 ? 00:00:00 kjournald
    822 ? 00:00:01 udevd
    1170 ? 00:00:00 kgameportd
    1172 ? 00:00:00 khubd
    1913 ? 00:00:00 kjournald
    2250 ? 00:00:00 acpid
    2270 ? 00:00:00 syslog-ng
    2273 ? 00:00:00 klogd
    2317 ? 00:00:00 resmgrd
    2332 ? 00:00:00 dbus-daemon
    2358 ? 00:00:00 polkitd
    2371 ? 00:00:01 hald
    2372 ? 00:00:00 hald-runner
    2497 ? 00:00:00 hald-addon-acpi
    2507 ? 00:00:00 hald-addon-keyb
    2821 ? 00:00:00 hald-addon-stor
    2828 ? 00:00:00 hald-addon-stor
    2999 ? 00:00:00 portmap
    3019 ? 00:00:00 auditd
    3025 ? 00:00:00 kauditd
    3114 ? 00:00:00 nscd
    3130 ? 00:00:00 cupsd
    3180 ? 00:00:01 zmd
    3288 ? 00:00:00 cron
    3322 ? 00:00:00 smpppd
    3327 ? 00:00:00 sshd
    3370 ? 00:00:00 gdm
    3380 ? 00:00:00 startpar
    3388 tty1 00:00:00 mingetty
    3392 tty2 00:00:00 mingetty
    3396 tty3 00:00:00 mingetty
    3398 tty4 00:00:00 mingetty
    3399 tty5 00:00:00 mingetty
    3412 tty6 00:00:00 mingetty
    3419 ? 00:00:00 gdm
    3446 tty7 00:00:19 X
    3639 ? 00:00:00 gnome-session
    3690 ? 00:00:00 gpg-agent
    3691 ? 00:00:00 ssh-agent
    3695 ? 00:00:00 dbus-daemon
    3699 ? 00:00:01 gconfd-2
    3708 ? 00:00:00 gnome-keyring-d
    3710 ? 00:00:00 gnome-settings-
    3718 ? 00:00:00 esd
    3733 ? 00:00:01 metacity
    3740 ? 00:00:01 gnome-panel
    3742 ? 00:00:06 nautilus
    3744 ? 00:00:00 bonobo-activati
    3751 ? 00:00:00 gnome-vfs-daemo
    3757 ? 00:00:01 zen-updater
    3778 ? 00:00:04 application-bro
    3788 ? 00:00:11 main-menu
    3790 ? 00:00:01 tomboy
    3792 ? 00:00:00 mixer_applet2
    3793 ? 00:00:00 gnome-volume-ma
    3813 ? 00:00:00 nm-applet
    3823 ? 00:00:00 gnome-power-man
    3842 ? 00:00:00 mapping-daemon
    3885 ? 00:00:00 gnome-screensav
    3888 ? 00:00:01 gnome-terminal
    3890 ? 00:00:00 gnome-pty-helpe
    3891 pts/0 00:00:00 bash
    4185 ? 00:00:09 gedit
    4239 ? 00:00:00 soffice
    4253 ? 00:00:05 soffice.bin
    4280 pts/1 00:00:00 bash
    4285 pts/1 00:00:00 ps

    den befehl iwilist wie gewünscht:
    iwlist [interface] scanning [essid NNN] [last]
    [interface] frequency
    [interface] channel
    [interface] bitrate
    [interface] rate
    [interface] encryption
    [interface] keys
    [interface] power
    [interface] txpower
    [interface] retry
    [interface] ap
    [interface] accesspoints
    [interface] peers
    [interface] event
    [interface] auth
    [interface] wpakeys
    [interface] genie
    [interface] modulation

    IWCONFIG:
    wlan21 Link encap:Ethernet HWaddr 00:04:0E:CE:D1:6D
    inet6 addr: fe80::204:eff:fece:d16d/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:6 errors:6 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:468 (468.0 b)

    LSUSB:
    Bus 004 Device 002: ID 057c:6201 AVM GmbH
    Bus 004 Device 001: ID 0000:0000
    Bus 003 Device 001: ID 0000:0000
    Bus 002 Device 001: ID 0000:0000
    Bus 001 Device 001: ID 0000:0000

    lsmod:
    Module Size Used by
    iptable_filter 7168 0
    ip_tables 17604 1 iptable_filter
    x_tables 18180 1 ip_tables
    joydev 13504 0
    ipv6 263584 12
    snd_pcm_oss 53376 0
    snd_mixer_oss 21248 1 snd_pcm_oss
    snd_seq_midi 13824 0
    snd_emu10k1_synth 12544 0
    snd_emux_synth 41984 1 snd_emu10k1_synth
    snd_seq_virmidi 11392 1 snd_emux_synth
    snd_seq_midi_event 11520 2 snd_seq_midi,snd_seq_virmidi
    snd_seq_midi_emul 10624 1 snd_emux_synth
    snd_seq 60272 5 snd_seq_midi,snd_emux_synth,snd_seq_virmidi,snd_seq_midi_event,snd_seq_midi_emul
    button 10896 0
    battery 14340 0
    ac 9476 0
    apparmor 55572 0
    aamatch_pcre 18304 1 apparmor
    loop 20488 0
    dm_mod 60184 0
    fwlanusb 612416 0
    ide_cd 42272 0
    cdrom 38432 1 ide_cd
    via_rhine 28680 0
    mii 9600 1 via_rhine
    ns558 8960 0
    via_ircc 24980 0
    shpchp 40224 0
    ehci_hcd 34696 0
    uhci_hcd 26892 0
    irda 132152 1 via_ircc
    crc_ccitt 6272 1 irda
    i2c_viapro 12308 0
    i2c_core 25216 1 i2c_viapro
    pci_hotplug 35136 1 shpchp
    emu10k1_gp 7936 0
    via_agp 14080 1
    usbcore 114896 3 fwlanusb,ehci_hcd,uhci_hcd
    gameport 19464 4 ns558,emu10k1_gp
    snd_emu10k1 125728 2 snd_emu10k1_synth
    agpgart 35528 1 via_agp
    snd_rawmidi 29824 3 snd_seq_midi,snd_seq_virmidi,snd_emu10k1
    snd_ac97_codec 95648 1 snd_emu10k1
    snd_ac97_bus 6400 1 snd_ac97_codec
    snd_pcm 86916 3 snd_pcm_oss,snd_emu10k1,snd_ac97_codec
    snd_seq_device 12812 6 snd_seq_midi,snd_emu10k1_synth,snd_emux_synth,snd_seq,snd_emu10k1,snd_rawmidi
    snd_timer 27908 3 snd_seq,snd_emu10k1,snd_pcm
    snd_page_alloc 14472 2 snd_emu10k1,snd_pcm
    snd_util_mem 9472 2 snd_emux_synth,snd_emu10k1
    snd_hwdep 13956 2 snd_emux_synth,snd_emu10k1
    snd 61188 18 snd_pcm_oss,snd_mixer_oss,snd_seq_midi,snd_emu10k1_synth,snd_emux_synth,snd_seq_virmidi,snd_seq_midi_emul,snd_seq,snd_emu10k1,snd_rawmidi,snd_ac97_codec,snd_pcm,snd_seq_device,snd_timer,snd_util_mem,snd_hwdep
    soundcore 13792 1 snd
    ext3 141192 2
    mbcache 12804 1 ext3
    jbd 70324 1 ext3
    edd 13892 0
    fan 8964 0
    thermal 18568 0
    processor 34664 1 thermal
    via82cxxx 12804 0 [permanent]
    ide_disk 20480 4
    ide_core 129992 3 ide_cd,via82cxxx,ide_disk
     
  11. #10 24. April 2007
    AW: Open Suse 10.2 WLAN problem

    also mit ndiswrapper funktioniert das einwandfrei. Versuch doch mal unter openSUSE.org zu gehen und gebe dort dann, ndiswrapper oder wlan als stichwort, vielleicht findest du ja was nützliches
     
  12. #11 26. April 2007
    AW: Open Suse 10.2 WLAN problem

    problem hatt sich erledigt!^^

    Wie ich vorgegangen bin?
    Hab Open Suse nochmal neu installiert, Ndiswrapper frisch drauf
    die Dateien von der AVM fritz CD auf die Linux Platte kopiert lange rumbrobiert bis es dan ging.

    (was allerdings jetzt ist ,das der Stick sich so ca alle 30min einfach auschaltet bzw die Leds ausgehen.
    und den Rechner wieder neu starten muss)

    [kann closed werden]

    PS: gibt für euch ne bw
    Danke nochmal

    gruß Annonymous01503
     

  13. Videos zum Thema
Die Seite wird geladen...
Similar Threads - Open Suse WLAN
  1. Antworten:
    0
    Aufrufe:
    1.741
  2. Minecraft unter OpenSuse 12.2

    iPoD.freaK , 31. Oktober 2012 , im Forum: Linux & BSD
    Antworten:
    8
    Aufrufe:
    2.070
  3. openSUSE Treiber Netzwerkkarte

    xXsoureXx , 25. Oktober 2012 , im Forum: Linux & BSD
    Antworten:
    2
    Aufrufe:
    1.741
  4. Antworten:
    0
    Aufrufe:
    271
  5. Antworten:
    9
    Aufrufe:
    383