[PHP] verlinken klappt nicht

Dieses Thema im Forum "Webentwicklung" wurde erstellt von $yNf0o, 28. Januar 2007 .

Schlagworte:
Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 28. Januar 2007
    verlinken klappt nicht

    hallo leute!
    also ich habe folgendes problem. ich habe eine index.php mit diesem script drinnen:
    PHP:
    <? php  
            
    if(empty( $_GET [ 'main' ]))  
            
    $_GET [ 'main' ] =  "home" ;  
            if(
    file_exists ( "content/" . $_GET [ 'main' ]. ".php" )) {  
            include(
    "content/" . $_GET [ 'main' ]. ".php" );  
            } else {  
            include(
    "content/error.php" );}  
    ?>
    dieser schnipsel ließt die .php dateien aus dem ordner /content aus und includet sie mir in meine index.php! die links schauen danach so aus ...index.php?main="irgendwas aus dem content ordner"

    so und etz das problem es funktioniert alles wunderbar und superduper hab mich auch voll gefreut als ich diesen code fand (endlich keine iframes mehr^^) aber wenn ich damit scripte verlinken (includen) möchte dann stimmen alle links in den scripten selbst nicht mehr. ich weiß auch nicht warum, es schaut danach aus das die scripte dann auf das ?main="irgendwas" zurückgreifen aber das dann doch falsch ist ka^^. Irgendwie muss es doch noch möglich sein ein php script per link in meine index.php einzufügen ohne das die links nicht mehr funktionieren!

    ich bitte um hilfe hab schon 1000 von newsscripten durchprobiert aber bei allen das selbe die comment funktion als link geht nicht mehr oder irgendwelche anderen links gehen nicht.... (alle script internen links gehen nicht^^).

    danke für die mühen BW ist auf jedenfall für jeden nützlichen post drin^^

    mfg $yNf0o
     

  2. Anzeige
  3. #2 28. Januar 2007
    AW: verlinken klappt nicht

    "die links gehen dann nichtmehr" ist viel zu ungenau. Was geht genau nicht ? Was komme nfür fehler ? Wie sehen die entsprechenden links aus ?

    Paar mehr infos braucht man da schon
     
  4. #3 28. Januar 2007
    AW: verlinken klappt nicht

    also folgende allbekannte skripte hab ich durchprobiert:
    webnews
    cutenews
    bsx-news
    para-news
    und bei jedem das gleiche porblem: script funzt einwandfrei sobalt man es in einem externen window offen hat alle funktionen wie comment schreiben, news posten oder die edit funktion gehen als intern ins script eingebaute links. aber sobalt ich sie mit dem oben beschriebenen code include funktioniert zwar noch das script aber diese links gehen nicht mehr.
    immer wenn ich dann einen anklicke wird die home.php includet die als startseite agiert.
    ich habe keinen plan an was das liegen kann aber ich glaube das bei diesem php-befehl es mit allen skripten so ergehen wird.

    naja ich hoffe das ichs jetzt genau beschrieben habe. wenn nicht dann genau nachfragen was ihr wissen wollt.

    und wenns euch weiter bringt ich habe sie auf dem neuen xampp getestet.

    ps: gibt es keine andere möglichkeit so ein script aufzurufen ohne das irgendwelche fehler kommen?

    danke für die hilfe 1x BW ist schon raus!^^
     

  5. Videos zum Thema
Die Seite wird geladen...
Similar Threads - PHP verlinken klappt
  1. Antworten:
    4
    Aufrufe:
    6.082
  2. Antworten:
    2
    Aufrufe:
    453
  3. Antworten:
    5
    Aufrufe:
    253
  4. Antworten:
    9
    Aufrufe:
    550
  5. [PHP] Hilfe beim verlinken

    FritzPtiz , 4. Januar 2007 , im Forum: Webentwicklung
    Antworten:
    4
    Aufrufe:
    251
  • Annonce

  • Annonce