SuSe 10.1 Prob mit Intel WLAN 3945ABG

Dieses Thema im Forum "Linux & BSD" wurde erstellt von mcgudiguz, 22. November 2006 .

Schlagworte:
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 22. November 2006
    kann mir jemand sagen ob es mit der Intel PRO 3945ABGWireless problem gibt bezüglich SuSe 10.1 ? Das wär mir ganz arg wichtig, weil früher hatte ich die alte Intel Pro Wlan weiß nicht mehr wie die hieß 2XXX und die wurde nicht erkannt, gabs auch keine vernünftigen Treiber etc. sprich hat jemand die Konfiguration? Ich denke mal ganz bestimmt oder, dürfte ja nicht unüblich sein. würde das wieder nicht funktionieren spar ich mir die ganze arbeit mit installieren... google gibt auch nichts her.
     

  2. Anzeige
    Dealz: stark reduzierte Angebote finden.
  3. #2 23. November 2006
    AW: SuSe 10.1 Prob mit Intel WLAN 3945ABG

    Hallo,

    folgendes habe ich gefunden. Ich hoffe das hilft Dir!

    Code:
    The following is a step-by-step instruction on how to get your Intel 3945abg wireless card configured in SuSE 10.0.
    
    Step 1: Download ieee80211 version 1.1.11 (version 1.1.12 may also work, but I haven't tried). DO NOT USE VERSION 1.1.13 - IT WILL NOT WORK WITH INTEL'S 1.0.0 STABLE DRIVERS!!! You can get the file here: http://ieee80211.sourceforge.net/#downloads
    
    Step 2: Untar, compile, and install the ieee80211 by running the following commands. Note, if it prompts you to remove old versions of ieee80211, select yes.
    
    # tar xvzf ieee80211-1.1.11.tgz
    # cd ieee80211-1.1.11
    # make
    # make install
    
    Step 3: Download the Intel 1.0.0 stable drivers here: http://downloadfinder.intel.com/scripts-df-external/detail_desc.aspx?ProductID=2259&DwnldID=10315&agr=Y
    
    Step 4: Untar the file with the command:
    
    # tar xvzf ipw3945-linux-1.0.0.tgz
    # cd intel-ipw3945-1.0.0[/b]
    
    Step 5: After you untar the file, there will be 3 additional tar files: the intel driver, the microcode, and the regulartory deamon. Install the microcode by typing the following:
    
    # tar xvzf ipw3945-ucode-1.13.tgz
    # cp ipw3945-ucode-1.13/ipw3945.ucode /lib/firmware/
    
    Step 6:: Install the regulartory deamon by typing:
    
    # tar xvzf ipw3945d-1.7.18.tgz
    # cp ipw3945d-1.7.18/x86/ipw3945d /sbin/
    
    or, if you have an 64bit cpu:
    
    # cp ipw3945d-1.7.18/x86_64/ipw3945d /sbin/
    
    
    Step 7: Now compile and install the Intel drivers.
    
    # tar xvzf ipw3945-1.0.0.tgz
    # cd ipw3945-1.0.0
    # make
    # cp ipw3945.ko /lib/modules/$(uname -r)
    # depmod -a
    
    Step 7: Configure to auto launch the regulartory deamon and Intel module by add the following your /etc/modprobe.conf.local file:
    
    install ipw3945 /sbin/modprobe --ignore-install ipw3945 ; sleep 0.5 ; /sbin/ipw3945d --quiet
    
    Step 8: Restart your computer and the module will automaticaly load. You can verify everything is working by typing:
    
    # iwconfig
    
    You should see your list of wireless network interfaces like this:
    
    
    lo no wireless extensions.
    
    eth0 no wireless extensions.
    
    eth1 unassociated ESSID:off/any
    Mode:Managed Channel=0 Access Point: 00:00:00:00:00:00
    Bit Rate=0 kb/s Tx-Power:16 dBm
    Retry limit:15 RTS thr:off Fragment thr:off
    Encryption key:off
    Power Management:off
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:1388 Missed beacon:0
    
    
    Hope this helps other people!
    
    Now, the only thing I have left to do is configure the wireless card to use WPA. I'm also having trouble where YAST doesn't recognize the card as a wireless card. I'll work this later - I have to get back to work before I get fired.
    
    Additional info, if you wish to have encryption with WPA enabled, be sure to install the wpa_supplicant package via YAST. Reconfigure your wireless card and you should be set.
    
    BTW - in my post above, I forgot to mention you may have to reconfigure your your new wirless card via YAST and change the device type for "Ehternet" to "Wireless" in order to have the ability to set wireless encryption, etc.
    
    onlinepilot
     
  4. #3 23. November 2006
    AW: SuSe 10.1 Prob mit Intel WLAN 3945ABG

    vielmals danke... wo hast du das gefunden ? bzw. da steht ja das der hinweis für yast noch kommt wegen der verschlüsselung. aber das ist so schonmal sehr gut !
     
  5. #4 23. November 2006
    AW: SuSe 10.1 Prob mit Intel WLAN 3945ABG

    Hatte das noch irgendwo im Bookmark.

    Immer gerne!

    onlinepilot
     

  6. Videos zum Thema
Die Seite wird geladen...
Similar Threads - SuSe Prob Intel
  1. Antworten:
    3
    Aufrufe:
    1.269
  2. Remote-Desktop (VNC) openSUSE Problem

    Emoc0re , 16. September 2009 , im Forum: Linux & BSD
    Antworten:
    4
    Aufrufe:
    1.928
  3. Antworten:
    1
    Aufrufe:
    755
  4. [Linux] Suse 10.3 Sprachproblem

    Tokatci , 28. November 2007 , im Forum: Linux & BSD
    Antworten:
    0
    Aufrufe:
    345
  5. Antworten:
    10
    Aufrufe:
    597