Excel =WENN Formel in doppelter Abfrage

Dieses Thema im Forum "Windows" wurde erstellt von Buzzer, 13. März 2007 .

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 13. März 2007
    Hi,

    ich versuche eine Wenn/Dann Formel zu schreiben komm aber nicht weiter.

    Ich möchte das Excel überprüft ob in B2 "Herr" steht wenn ja soll er "Sehr geehrter Herr" schreiben Wenn "Frau" steht soll er "Sehr geehrte Frau" schreiben und wenn nichts oder etwas anderes steht dann soll er "Sehr geehrte Damen und Herren" schreiben.

    Meine Formel bis jetzt:
    Code:
    =WENN(B2 = "HERR";"Sehr geehrter Herr";(=WENN(B2 = "FRAU";"Sehr geehrte Frau";"Sehr geehrte Damen und Herren,"))
    Zudem wäre es klasse wenn er schreiben könnte: "Sehr geehrter Herr C2," in C2 steht der Name des Herren oder dann "Sehr geehrte Frau C2," und wenn er "Sehr geehrte Damen und Herren," schreibt dann kein Name also nix.

    Wäre so nice wenn ihr mir helfen könntet ich hatte es schonmal zusammen bekommen aber leider ist das ein paar Jahre her und ich find es nicht mehr :( BW mit Power 16 ist euch gewiss!
     

  2. Anzeige
    Dealz: stark reduzierte Angebote finden.
  3. #2 13. März 2007
    AW: Excel =WENN Formel in doppelter Abfrage

    Also auf den ersten Blick sollt es eigentlich passen ^^
    Aber Excel hat doch ne art Formelassistent, der generiert dir die Formel und dann passts

    Vor das 2. Wenn kein = , nen anderen Fehler seh ich grade nicht
     
  4. #3 13. März 2007
    AW: Excel =WENN Formel in doppelter Abfrage

    das, was die fehlte, war das "hallo herr " & C2.

    Code:
    =WENN(E8="Herr";"Sehr geehrter Herr "&F8;WENN(E8="Frau";"Sehr geehrte Frau "&F8;"Sehr geehrte Damen und Herren"))
    zellen musste noch angleichen, hab zum testen andere werte genommen.
     
  5. #4 13. März 2007
    AW: Excel =WENN Formel in doppelter Abfrage

    also, fehler in deiner formel.

    1. leerzeichen vor und nach der "=" ... funktionieren zwar sehen aber miserabel aus. lass sie weg.
    2. der schwarz makierte bereich, das "(=" hat dort nichts zu suchen.

    =WENN(B2 = "HERR";"Sehr geehrter Herr";(=WENN(B2 = "FRAU";"Sehr geehrte Frau";"Sehr geehrte Damen und Herren,"))

    3. Texte gehören niemals in Formeln geschrieben. wenn du dann mal etwas daran ändern willst, ist das immer etwas kompliziert.

    daher habe ich jetzt hier in die Zellen K2, K3 und K4 die Texte "Sehr geehrter Herr, Sehr geehrte Frau und Sehr geehrte Damen und Herren geschrieben.

    dann, wenn du die beiden verketten willst,

    also, sehr geehrte Frau [Name aus spalte c] geht das über die Formel "verketten"

    probiere einmal diese Funktion in Excel, sie sollte funktioneren. und du kannst sie beliebig nach unten ziehen.

    Code:
    =WENN(B2="HERR";VERKETTEN($K$2;" ";C2);WENN(B2="FRAU";VERKETTEN($K$3;" ";C2);VERKETTEN($K$4;" ";C3)))
    
    mfg spotting
     
  6. #5 13. März 2007
    AW: Excel =WENN Formel in doppelter Abfrage

    gibt's 'nen unterschied zwischen
    Code:
    verketten("lala";"muh")
    und
    Code:
    "lala" & "muh"
    , abgesehen von excel-funktion bzw. visual-basic-syntax?
     
  7. #6 13. März 2007
    AW: Excel =WENN Formel in doppelter Abfrage

    im grunde genommen nein,

    aber ich bin der meinung, dass man in excel, wenn man mit formeln rechnet, auch formeln eingeben sollte, damit jeder den sinn dieser formel nachschlagen kann. dafür sind die excel hilfe und der formelassistent durchaus geeignet.

    mfg
     
  8. #7 13. März 2007
    AW: Excel =WENN Formel in doppelter Abfrage

    joa macht sinn, aber ich benutz lieber die programmierer-variante ;) hab außerdem immer mal probleme mit klammern in diesem einzeiligen eingabefeld. naja, persönliche vorliebe, kann man drüber streiten.
     
  9. #8 13. März 2007
    AW: Excel =WENN Formel in doppelter Abfrage

    Also ich habe die schöner version mit dem Verketten genommen BW sind an euch alle raus ;) Super arbeit das hätte ich so nie hinbekommen *g THX und closed
     

  10. Videos zum Thema
Die Seite wird geladen...
Similar Threads - Excel WENN Formel
  1. Antworten:
    1
    Aufrufe:
    949
  2. Antworten:
    1
    Aufrufe:
    718
  3. Antworten:
    0
    Aufrufe:
    427
  4. Antworten:
    3
    Aufrufe:
    423
  5. Antworten:
    18
    Aufrufe:
    1.241