janrufmonitor

Dieses Thema im Forum "Linux & BSD" wurde erstellt von char0n, 29. März 2009 .

  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 29. März 2009
    Hallo,

    ich weiß nich ob ihr das oben genannte programm kennt aber ich hoffe es einfach mal;-)
    und zwar versuch ich das Programm über die Konsole zu starten das funktioniert eig. auch aber es kommt trotzdem eine Fehlermeldung und zwar:

    Code:
    Exception in thread "CapiMonitorNotifier" java.lang.UnsatisfiedLinkError: nRegister
     at de.powerisdnmonitor.capi.PIMCapi.register(PIMCapi.java:202)
     at de.powerisdnmonitor.capi.PIMCapi.register(PIMCapi.java:197)
     at de.powerisdnmonitor.capi.CapiMonitor$CapiMonitorNotifier.register(CapiMonitor.java:418)
     at de.powerisdnmonitor.capi.CapiMonitor$CapiMonitorNotifier.run(CapiMonitor.java:108)
     at java.lang.Thread.run(libgcj.so.81)
    Also das Programm ist dafür da um die ISDN Leitung "abzuhören" also um einkommende Anrufe zu protokollieren das funktioniert aber nich und nun hoffe/denke ich das dass an dem Fehler liegt.
    Falls jemand noch eine ALternative zu dem Programm wüßte wär das auch okay...
     

  2. Anzeige
    Dealz: stark reduzierte Angebote finden.
  3. #2 29. März 2009
    AW: janrufmonitor

    Einige weitere Informationen wären ganz schön, z.B. welche Distribution(+Version) du nutzt....
    Ansonsten könntest du dir mal die Dokumentation ansehen oder in deren Community posten.

    Für den Fall, das du eine Debian-basierte Distri benutzt (falls der Befehl nicht Debian-spezifisch ist belehrt mich bitte eines besseren...) könntest du folgendes (als root) mal probieren:
    Code:
    update-alternatives --config java 
    update-alternatives --config javac
    
    Dort musst du dann die Sun JAVA jre auswählen...
    Dein Problem rührt vermutlich daher, das die Gnu Java Version nicht kompatibel mit dem Programm ist, deswegen benötigst du die Sun Java JRE.

    MFG
    TuXiFiED
     
  4. #3 29. März 2009
    AW: janrufmonitor

    Danke schonma für die Antwort

    habs gerad versucht mit Java Sun hat aber nichts gebracht ist immer noch der Gleiche fehler

    Benutze Ubuntu neueste Version kann dir gerad nich sagen welche
    Die Dokumentation hab ich mir schon angeguckt hat mir aber nich weitergeholfen!
     

  5. Videos zum Thema