[PHP] [Problem] Include gibt nix aus

Dieses Thema im Forum "Webentwicklung" wurde erstellt von ggo, 12. April 2007 .

Schlagworte:
Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 12. April 2007
    [Problem] Include gibt nix aus

    Moin,

    hänge nun seit Stunden an meiner Page und bin langsam echt am verzweifeln.
    Ich will nen einfachen Textcounter einbinden und dazu muss ich in einen echo' ein include reinbekommen.

    Der Code sieht wie folgt aus:

    PHP:
    echo'
    <title>xxx.de</title>
    <link href="extra/xxx.css" rel="stylesheet" type="text/css">
    </head>

    <body>
    <div id="wrapper">

    <table width="100%" style="border: 1px dashed #606060;" cellspacing="0" cellpadding="0">
      <tr>
        <td height="101" background="images/bruhsdak/main_header.jpg" align=left><img src="images/logo.gif" border="0"  alt=""></td>
      </tr>
      <tr>
        <td height="15" background="images/message.jpg" align=left>&nbsp;&raquo; '; echo message(); echo'</td>
      </tr>
      <tr>
        <td>
          <table border="0" cellpadding="0" cellspacing="0" width="100%">
            <tr valign="top">
              <td width="160" bgcolor="#f0f0f0">
                <table width="100%" cellpadding="2" cellspacing="5" border="0">
                  <tr valign="top">
                    <td class="sidebar">
                        <table class="main" cellspacing="1" cellpadding="4" style="table-layout:fixed;">
                            <tr>
                              <td class="head" >Navigation</td>
                            </tr>
                            <tr>
                              <td class="con1" align="left">About</td>
                            </tr>
                            <tr>
                              <td class="con1" align="left">Bilder</td>
                            </tr>
                            <tr>
                 <td class="con1" align="left">Kontakt</td>
                            </tr>
                        </table>

                        <table><tr><td></td></tr></table>
                    
                    <table class="main" cellspacing="1" cellpadding="4" style="table-layout:fixed;">
                    <tr>
                      <td class="head">Besucher:</td>
                    </tr>
                    <tr>
                      <td class="con1"><a href="'.$PHP_SELF.'?id=modules/online&action=guests">Aktuelle Besucher: '.$OnlineCount.'</a></td>
                    </tr>
                    <tr>
                      [COLOR="Red"]<td class="con1">Gesamt Besucher: <?  include ( "flount.php" ); ?></td>[/COLOR]
                    </tr>
                    </table>

                    </td>
                  </tr>
                </table>
              </td>
              <td bgcolor="#cccccc" background="extra/line.gif" width="1"></td>
              <td bgcolor="#f0f0f0">
                <table cellpadding="0" cellspacing="5" width="100%">
                  <tr>
                    <td class="sidebar" valign="top">';
    Aber der include gibt eifach nix aus.

    Kurz gesagt ich will nach

    Einen

    machen.

    Aber es geht net.Wieso?

    Pls help me ;(
     

  2. Anzeige
    Dealz: stark reduzierte Angebote finden.
  3. #2 12. April 2007
    AW: [Problem] Include gibt nix aus

    Hi
    Versteh das nicht ganz so genau aber n include geht doch ohne Klammern.

    Also: <? include datei.php; ?>

    In der datei.php sollte dann schon n echo-Befehl vorhanden sein, der was ausgibt . Zur Überprüfung kannste die ja so aufrufen und sehen WAS der ausgibt. Ebenfalls muss die Seite selber php sein und NICHT html, sons kann der mit dem include ja auch nix anfangen

    greetz
     
  4. #3 12. April 2007
    AW: [Problem] Include gibt nix aus

    Mich würde mal der Code der Includefile interessieren, warscheinlich ist da ein Fehler. Gibt die Includefile beim normalen Aufruf etwas aus?

    Und wenn ja, wie wäre es mal mit "<?php ..."
     
  5. #4 12. April 2007
    AW: [Problem] Include gibt nix aus

    wenn die zieldatei nicht kaputt ist dann wuerde ich mal sagen das muss
    Code:
     <? include'flount.php';?>
    heissen. denn ' ' ist nicht gleich " ". steht auch auf php.net so. probiers mal aus.
     
  6. #5 12. April 2007
    AW: [Problem] Include gibt nix aus

    Erstmal thx für euro Posts.

    1. Die Datei die included wird ist ok. Bei normalen Aufruf bekomme ich eine Zahl ausgegeben.
    2. Die Datei ist ne *.php


    @ MrMuhKuh

    Dein Vorschlag verursacht einen Fehler.
    Code:
    Parse error: syntax error, unexpected T_STRING, expecting ',' or ';' in XXX on line xxx
    Es handelt sich hierbei um die Zeile wo der include Befehl steht.
     
  7. #6 12. April 2007
    AW: [Problem] Include gibt nix aus

    probier mal folgendes:

    PHP:
    <? php  require( "./name.php" );  ?>
    bei require bricht dein script ab wenn zieldatei nicht vorhanden ist. ./ steht für "selbes verzeichniss"

    ps: ob " oder ' ist hier egal.
     
  8. #7 12. April 2007
    AW: [Problem] Include gibt nix aus

    @ Murdoc-4D

    Wenn ich deinen Befehl mit ' mache, bekomme ich:

    Code:
    <td class="con1">Gesamt Besucher: <?php require('./flount.php'); ?> </td>
    Code:
    Parse error: syntax error, unexpected '/'
    Und mit " passiert auch nix ?( Er gibt nur "Gesamt Besucher:" aus...
    Code:
    <td class="con1">Gesamt Besucher: <?php require("./flount.php"); ?> </td>
    Code:
    Gesamt Besucher:
     
  9. #8 12. April 2007
    AW: [Problem] Include gibt nix aus

    dann ist einfach nichts da was ausgegeben werden soll.
     
  10. #9 12. April 2007
    AW: [Problem] Include gibt nix aus

    wenn ich was include geht das mit
    <? include('flount.php'); ?>
    kann sein dass meine schreibweise vorhin etwas falsch war. :D

    ps: liegt den die datei im gleichen verzeichniss? ^^'
     
  11. #10 12. April 2007
    AW: [Problem] Include gibt nix aus

    Ja, die Datei liegt im gleichen Verzeichniss.
    Und mit deinen Include geht das net... dann sagt er mir
    Code:
    Parse error: syntax error, unexpected T_STRING, expecting ',' or ';' 
    Ich denke der Fehler wird verursagt weil das alles nach nem echo' kommt.
    Also echo ' [...] <? include('flount.php'); ?>
     
  12. #11 12. April 2007
    AW: [Problem] Include gibt nix aus

    Dann include die Datei doch mal vernünftig und lass den echo befehl aus der Datei.
    Stattdessen machse anstatt "echo" in der Datei "$test=".

    Jetzt hauste den Echo Befehl von der Variable test in dieser Datei.

    Also
    include datei.php;
    echo $datei;

    Das dürfte aber auf jeden Fall klappen!
    (Lass die Klammern und Striche beim includen ma weg! :D )
    greetz
     
  13. #12 12. April 2007
    AW: [Problem] Include gibt nix aus

    sehr lolig...

    das erste was mir auffällt...der ganze HTML-Kram steht in einem Echo...also muss vorher schon iwann sowas wie <?php kommen... dies versuchst du im echo dann nochma zu öffnen....

    Ich würde einfach mal sagen.... vor deinem Include befehl machst du dein ' um dein echo zu beenden... dann machste nen Zeilenumbruch und schreibst dahin include ('DATEI.php'); und dann machste echo neu auf mit echo' und dann den text weiter.....


    quasi:

    PHP:
    echo  ' laaaaaaaanger text' ;
    include(
    'Datei.php' );
    echo 
    ' weiter der laaaaange text' ;
     
  14. #13 12. April 2007
    AW: [Problem] Include gibt nix aus

    Jaaaa, habs hinbekommen... Danke stevo, du hast für den entscheidenen Denkanstoß bewirkt.

    @Gn0m

    Genau so hab ich nu gemacht ^^

    Big thx an alle die mir geholfen bzw. es versucht haben.

    :cool:
     
  15. #14 12. April 2007
    AW: [Problem] Include gibt nix aus

    Wozu soll das gut sein? Also ich versteh einfach nicht denn Sinn dahinter? In dieser Include Datei ist dann wieder html zu finden oder welchen Sinn soll das haben?

    Generelle Tipps:
    1. Design, HTML und PHP von einander trennen.
    2. echo, include und require sind PHP Sprachkonstrukte und sollten daher ohne () benutzt werden.
    3. Zum sinnvolleren Umgang mit Strings empfehle ich dir Echo
     

  16. Videos zum Thema
Die Seite wird geladen...
Similar Threads - PHP Problem Include
  1. Antworten:
    3
    Aufrufe:
    1.782
  2. Antworten:
    5
    Aufrufe:
    313
  3. Antworten:
    9
    Aufrufe:
    311
  4. [PHP] include problem

    Reaperchef , 22. Januar 2007 , im Forum: Webentwicklung
    Antworten:
    7
    Aufrufe:
    295
  5. Antworten:
    2
    Aufrufe:
    409
  • Annonce

  • Annonce