Wie glibc aktualisieren/installieren ?

Dieses Thema im Forum "Linux & BSD" wurde erstellt von myth2806, 24. November 2006 .

  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 24. November 2006
    Hi leutz,

    ich habe ein Problem mit meinem Debian/etch System. Und zwar geht es darum dass ich aufgefordert wurde während der installation eines programms glibc zu installieren. K kein plan ob ichs bei der Base-installation von Debian mitinstalliert habe auf jeden fall ist es nicht da oder nur eine veraltete version. Für mich am einfachsten wäre es wenn ich einfach per "apt-get install glibc" vorgehen könnte aber leider findet er das paket nicht -.-.
    hat nicht irgendwer quellen für die glibc die ich dann schöhn in meine sources.list eintragen könnte?

    thx im vorraus =)

    greez myth
     

  2. Anzeige
  3. #2 24. November 2006
    AW: Wie glibc aktualisieren/installieren ?

    schonmal per apt-cache search glibc danach gesucht? sollte eigentlich in apt drin sein
     
  4. #3 24. November 2006
    AW: Wie glibc aktualisieren/installieren ?

    ja gut danke dafür schonmal das ergab ne lange liste woraus ich mir die entsprechenden libs zusammensuchen konnte ^^
    allerdings hab ich jetzt das problem dem x-server zu sagen dass er den nvidia treiber statt dem vesa treiber verwenden soll. ich hab zwar als treiber in die /etc/X11/xorg.conf nvidia eingetragen allerdings funktioniert der server jetzt nicht mehr. laut der readme der nvidia treiber musste ich dann auch noch zwei module aus der liste löschen, das hab ich auch gemacht. aber immer wenn ichs starten will passiert erstmal gar nichts und dann ein fehlerbericht. Aus diesem bericht kann ich dann entnehmen dass er probleme hat den screen zu finden. k also dann hab ich in der config eine zeile gefunden mit sowas wie dem namen des treibers. darauf hab ich als treiber name geforcew angegeben und dass dann auch unten eingetragen. leider stürzr nun mein rechner ab sobald ich versuche x zu starten.

    hoffe dabei kann mir jetzt nochmalö wer helfen ^^

    greez myth
     
  5. #4 24. November 2006
    AW: Wie glibc aktualisieren/installieren ?

    upsss.~edited~^^

    naja, hier meine xorg.conf:

    Code:
    Section "ServerLayout"
     Identifier "Default Layout"
     Screen "Default Screen" 0 0
     InputDevice "Generic Keyboard"
     InputDevice "Configured Mouse"
    EndSection
    
    Section "Files"
    
     # path to defoma fonts
     FontPath "/usr/share/fonts/X11/misc"
     FontPath "/usr/X11R6/lib/X11/fonts/misc"
     FontPath "/usr/share/fonts/X11/cyrillic"
     FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
     FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
     FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
     FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
     FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
     FontPath "/usr/share/fonts/X11/Type1"
     FontPath "/usr/X11R6/lib/X11/fonts/Type1"
     FontPath "/usr/share/fonts/X11/100dpi"
     FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
     FontPath "/usr/share/fonts/X11/75dpi"
     FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
     FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    EndSection
    
    Section "Module"
     Load "i2c"
     Load "bitmap"
     Load "ddc"
     Load "extmod"
     Load "freetype"
     Load "glx"
     Load "int10"
     Load "type1"
     Load "vbe"
    EndSection
    
    Section "InputDevice"
     Identifier "Generic Keyboard"
     Driver "kbd"
     Option "CoreKeyboard"
     Option "XkbRules" "xorg"
     Option "XkbModel" "pc105"
     Option "XkbLayout" "de"
     Option "XkbVariant" "nodeadkeys"
    EndSection
    
    Section "InputDevice"
     Identifier "Configured Mouse"
     Driver "mouse"
     Option "CorePointer"
     Option "Device" "/dev/input/mice"
     Option "Protocol" "ExplorerPS/2"
     Option "Emulate3Buttons" "true"
    EndSection
    
    Section "Monitor"
     Identifier "Standardbildschirm"
     HorizSync 28.0 - 80.0
     VertRefresh 43.0 - 60.0
     Option "DPMS"
    EndSection
    
    Section "Device"
     Identifier "Standardgrafikkarte"
     Driver "nvidia"
    EndSection
    
    Section "Screen"
     Identifier "Default Screen"
     Device "Standardgrafikkarte"
     Monitor "Standardbildschirm"
     DefaultDepth 24
     SubSection "Display"
     Depth 1
     Modes "1280x1024" "1024x768" "800x600"
     EndSubSection
     SubSection "Display"
     Depth 4
     Modes "1280x1024" "1024x768" "800x600"
     EndSubSection
     SubSection "Display"
     Depth 8
     Modes "1280x1024" "1024x768" "800x600"
     EndSubSection
     SubSection "Display"
     Depth 15
     Modes "1280x1024" "1024x768" "800x600"
     EndSubSection
     SubSection "Display"
     Depth 16
     Modes "1280x1024" "1024x768" "800x600"
     EndSubSection
     SubSection "Display"
     Depth 24
     Modes "1280x1024" "1024x768" "800x600"
     EndSubSection
    EndSection
    
     
  6. #5 24. November 2006
    AW: Wie glibc aktualisieren/installieren ?

    ja thx dafür aber leider funktioniert es mit den dort angegebenen einstellungen auch nicht.
    allerdings hab ichs jetzt doch zum laufen bekommen. der grund war schlicht das ich die falschen treiber hatte -.-
    auf der nvidia seite gibt es ja die normalen treiber und die legacy treiber die angeblich besser für die neuere generation der grafikkarten entwickelt wurden (ich denke ich zähle mit einer geforce 7900 GT dazu). nun anscheinend hat der treiber nicht gehalten was er versprach.... ich habs mit dem anderen probiert und nach weiteren drei minuten an der xorg.conf rumbaun gings dann ^^

    also trotzdem thx an euch ^^

    greez myth
     

  7. Videos zum Thema
Die Seite wird geladen...
Similar Threads - glibc aktualisieren installieren
  1. Antworten:
    1
    Aufrufe:
    1.076
  2. Antworten:
    2
    Aufrufe:
    1.126
  3. Antworten:
    4
    Aufrufe:
    926
  4. [Linux] Glibcxx?

    HeroDX , 28. April 2008 , im Forum: Linux & BSD
    Antworten:
    3
    Aufrufe:
    348
  5. GLIBCXX_3.4.6 not found

    MasterJulian , 12. Juli 2006 , im Forum: Linux & BSD
    Antworten:
    3
    Aufrufe:
    327