2 Domains ein Ziel aber eine Domain mit Umlauten

Dieses Thema im Forum "Webentwicklung" wurde erstellt von [=Snake=], 30. März 2009 .

  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 30. März 2009
    Hallo zusammen,

    betreibe ein phpBB3 Board. Dabei habe ich 2 .de Domains die jeweils beide auf das Board hinführen.

    Da ich meinen Webdienst damals mit der Umlaut-Domain registriert habe, ist das die Hauptdomain. Wenn man sich unter der UD (Umlautdomain) in meinem Board anmeldet und registriert funktionieren die Cookies ohne problem. Geht man jedoch über die andere domain auf das Board funktionieren die Cookies nicht! Das ist das erste Problem!

    Das 2te problem ist Google Analytics: Man kann dort keine domains mit umleuten registrieren. wie schaffe ich es also es so einzustellen dass der nutzer eingeben kann:

    www.xxxxx.de und auf www.äääää.de weitergeleitet wird?! und auch die UD im adressfenster angezeigt wird?

    hat so eine umleitung auf die google bots?

    BWs gibts natürlich.
     

  2. Anzeige
    Dealz: stark reduzierte Angebote finden.
  3. #2 30. März 2009
    AW: 2 Domains ein Ziel aber eine Domain mit Umlauten

    Zu Problem eins..Wenn du ein phpBB3.0.x hast, hilft dir dieser Mod weiter:
    http://www.phpbb.com/community/viewtopic.php?f=69&t=885205&hilit=th23#p5056515

    Zu Problem zwei:
    Also user A geht auf http://www.xxx.de und wird weitergeleitet ohne, dass er es merkt auf http://www.wunschadresse. Die Url ändert sich auch im Browserfenster.

    Umzusetzen ist das ganze mit .htaccess

    Also einfach eine .htaccess im Rootverzeichnis der Domain erstellen
    Code:
    Redirect / http://www.wunschadresse.de/
    Wenn du das machst, ist aber logischerweise Problem eins auch gelöst, weil man immer umgeleitet wird.
     
  4. #3 31. März 2009
    AW: 2 Domains ein Ziel aber eine Domain mit Umlauten

    besser ist noch ein redirect 301, welcher der suchmaschine mitteilt dass die seite permanent auf eine domain umgezogen ist. Wird mit rewrite in der .htaccess festgelegt und ist auch eine Weiterleitung, nur halt besser für die suchmaschinen.
     
  5. #4 31. März 2009
    AW: 2 Domains ein Ziel aber eine Domain mit Umlauten


    kannst mir den code nochmal genau aufschreiben? ich bekomme nämlich wenn ich den befehl rein amche gar nicht mehr auf die hp weil es anscheind probleme mit den umlauten gibt! es werden dann "%?" zum beispiel angezeigt.
     
  6. #5 31. März 2009
    AW: 2 Domains ein Ziel aber eine Domain mit Umlauten

    Sollte normal das gleiche sein wie meins nur mit einer 301. Da benötigt man kein rewrite für.

    Code:
    redirect 301 / http://www.altedomain.de/ http://www.neuedomain.de/
    
    Funktioniert das nicht?
     
  7. #6 31. März 2009
    AW: 2 Domains ein Ziel aber eine Domain mit Umlauten

    geht nicht :( hab es auch mal mit der xn-.. adresse probiert aber geht das gleiche!
     
  8. #7 31. März 2009
    AW: 2 Domains ein Ziel aber eine Domain mit Umlauten

    Hast du eine Serverlog Datei auf die zugreifen kannst?

    Entweder im Webinterface oder wenn man via FTP connectet gibt es ein ordner mit "log" ect.
    Wenn ja schau mal da rein und guck mal kurz nach ob da was drin steht.


    EDIT://
    Ansonsten. Sorry hatte ein fehler drin. So geht das ganze
    Code:
    Redirect 301 / http://umleidungsdomain.de/
    
    / steht für das Root verzeichnis
     
  9. #8 31. März 2009
    AW: 2 Domains ein Ziel aber eine Domain mit Umlauten

    habe viele log-dateien...nach was soll ich den suchen?
     
  10. #9 31. März 2009
    AW: 2 Domains ein Ziel aber eine Domain mit Umlauten

    Schau mal mein Edit an. Hatte ein Fehler drin. Man muss gar nicht die vorher nachher Domain definieren. Habs auch gerade getestet bei mir.
     
  11. #10 31. März 2009
    AW: 2 Domains ein Ziel aber eine Domain mit Umlauten

    ich verzweifel langsam:
    also laut acp des webservers laufen beide domains so:

    1. http://www.xxx.de/Forum
    2. http://www.äää.de/Forum

    wenn ich die .htaccess im Forum ordner wie oben beschrieben ändere dann komme ich wieder nicht auf die hp und statt der umlaute werden "%?" angezeigt. muss ich die .htacess vllt in das Hauptverzeichniss, also VOR den Forumordner legen? und die http://www.xxx.de/Forum auf http://www.xxx.de ändern?

    Danke übringens das du dich damit befasst!
     
  12. #11 31. März 2009
    AW: 2 Domains ein Ziel aber eine Domain mit Umlauten

    Hey kein Problem. Ja also die .htaccess Datei sollte in das Root Verzeichnis und nicht in den Forum Ordner. Dann sollte das ganze auch ohne Probleme funktionieren.

    Wenn das ganze dann aber immernoch nicht will und die weiterleitung wichtig ist, würde ich das ganze erstmal mit eine PHP 301 weiterleitung machen, bis man den Fehler gefunden hat.

    PHP:
    <? php
    // Permanent redirection
    header ( "HTTP/1.1 301 Moved Permanently" );
    header ( "Location: http://äää.de/" );
    exit();
    ?>

    Ach stimmt ja..
    Okay oder ein versuch der doch mit Mod Rewrite arbeitet.
    Code:
    rewriteEngine on
    rewriteRule ^$ http://äää.de/ [R=permanent,L]
    
     
  13. #12 1. April 2009
    AW: 2 Domains ein Ziel aber eine Domain mit Umlauten

    schreib in deine index.php:
    PHP:
    <? php
        $host 
    getEnv ( 'HTTP_HOST' );
        if(
    preg_match ( '/^(?:www.)?xxx\.de$/' $host )) {
            
    header ( 'HTTP/1.1 301 Moved Permanently' );
            
    header ( 'location: htp://äöü.de' );
            exit;
        }
    ?>
     
  14. #13 2. April 2009
    AW: 2 Domains ein Ziel aber eine Domain mit Umlauten

    Funktioniert alles nicht! Egal was ich eintippe er zeigt mir die URL mit � anstelle der Umlaute an :(

    Habe bei der http://www.xxx.de-Adresse im ACP die Umleitung auf http://www.xxx.de/Forum rausgenommen. Eure Befehle abwechselnd versucht aber geht nicht. Rufe ich http://www.xxx.de auf so erscheint http://www.���.de und der typische Text das es nicht funktioniert.

    habe die .htaccess mal in das rootverzeichnis gepackt und ausprobiert oder den text in die index.php geschrieben - nada :(

    EDIT: ich kann die .htaccess aber auch gar nicht aus dem Forum ordner rausnehmen denn sonst geht gar keine adresse mehr!
     

  15. Videos zum Thema
Die Seite wird geladen...
Similar Threads - Domains Ziel aber
  1. Antworten:
    3
    Aufrufe:
    1.013
  2. Antworten:
    4
    Aufrufe:
    1.518
  3. Antworten:
    2
    Aufrufe:
    1.148
  4. Antworten:
    2
    Aufrufe:
    945
  5. Mehrere Domains oder nur eine?

    Creused , 23. September 2013 , im Forum: Hosting & Server
    Antworten:
    1
    Aufrufe:
    1.188
  • Annonce

  • Annonce