align / margin Problem - IE und Firefox

Dieses Thema im Forum "Webdesign" wurde erstellt von gdf, 5. Februar 2009 .

Schlagworte:
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 5. Februar 2009
    Moin und sorry für den Titel... mir ist nichts eingefallen...

    Ich habe folgendes Problem:

    Ich habe eine Seite erstellt mit einem durchgehenden Header inkl. Logo. Im Internet Explorer ist alles in Ordnung! Der Hintergrund stimmt mit dem Logo 1 zu 1 überein. Im Firefox ist es aber so, das dass Logo um ca. 10px nach unten verschoben ist.

    Ich habe es mit mehreren Codes ausprobiert! Keine lief im Moment... Laut google scheinen die Probleme zum Teil ja bekannt zu sein!

    Folgendes habe ich getestet:

    Normaler HTML Code (hier gehts im IE aber nicht mit FF):
    Code:
    <body background="background.jpg" topmargin="0" leftmargin"0" >
    <p><img src="header.jpg" />
    
    Via css:

    css:
    Code:
    #header {
     background-color : #000000;
     margin-top:0px;
     margin-left:0px;
    }
    
    Code:
    Code:
    <div id="header" style="align:top; margin:0px; float:top; ">
    <img src="header.jpg">
    </div>
    
    Kein Plan wo der Fehler steckt oder man diesen Fehler umgehen kann... Alles mist :(
     

  2. Anzeige
  3. #2 5. Februar 2009
    Konkret fällt mir nur gerade dieser Fehler im CSS auf:

    Code:
    #header {
     [COLOR="Red"]background.color[/COLOR] : #000000;
     margin-top:0px;
     margin-left:0px;
    }
    Es heisst "background-color".

    Für weitere Hilfe versteh ich zu wenig vom eigentlichen Problem, müsstest schon konkretere Informationen liefern.

    -mymaster
     
  4. #3 5. Februar 2009
    Zuletzt von einem Moderator bearbeitet: 14. April 2017
    Danke für den Hinweis ^^

    Ist aber garantiert nicht die Ursache für mein Problem...

    Hier ein Bild des Tatverdächtigen:

    [​IMG]
     
  5. #4 5. Februar 2009
    html
    {
    margin: 0px;
    padding: 0px;
    }

    probier mal das
     
  6. #5 5. Februar 2009
    hast du dem body schon margin:0; padding:0; gegeben ? wenn alle werte auf 0 sollen schreibe ich es eigentlich immer ohne px hatte schon oft sonst solche probleme wie du ... evtl mal mitm float probieren

    bzw am besten du machst die style sachen wirklich getrennt vom html wie ees sich eigentlich auch gehört also das bild beim bodytag im html wieder raus
    und
    body{

    }

    machen
     
  7. #6 5. Februar 2009
    Danke schomal...

    Aber geht trotzdem nicht...

    So sieht im Moment mein css aus:

    Code:
    #body {
     font-family: Arial, Helvetica, sans-serif;
     background-color: #000000;
     margin: 0; 
     padding: 0;
    }
    
    #header {
     background.color : #000000;
     margin-top:0;
     margin-left:0;
     padding:0;
     margin:0;
    }
    
    #html {
     margin: 0px;
     padding: 0px;
    }
    
    und eingebunden habe ich mit:

    Code:
    <div class="header" id="header">
    <img src="header.jpg>
    </div>
    
    Er arbeitet nur einwandfrei (jedenfalls im IE) wenn ich die Tags "topmargin="0" und leftmargin="0" im bodytag angebe.

    Soweit nicht schlimm... aber wie gesagt, kommt der gute Firefox damit irgendwie nicht klar :/
     
  8. #7 5. Februar 2009
    also beim body is ja keine id oder class deswegen im css einfach nur body ohne . oder #
    und wieso hast du beim div ne class und ne id drin? und beim #html genau wie beim body ohne # oder .


    sind die bilder gleich groß von der höhe und so? oder unterschiedlich sind sie im html eingebuden oder übers css?
     
  9. #8 5. Februar 2009
    Huch, ja habs auch gerade gesehen, das es wenig sinn macht!

    Die css hab ich nun bearbeitet...

    Die ID und Class hab ich rausgenommen und mit nem "style" versehen. Ist das überhaupt richtig?!

    Die Bilder haben beide die gleiche Höhe. Ich habe sie direkt im html eingebunden, will später noch ne Map draufballern.

    Ich verstehe es nur nicht, warum das alles im Firefox nicht geht...

    Der Code ist laut Dreamweaver soweit in Ordnung (Browserkompatiblitätsprüfung).

    Das einzige was er ausspuckt ist:

    "Das Tag: "body" hat kein Attribut: "topmargin" in den aktuellen Versionen.[XHTML 1.0 transitional]"

    Der Tag läuft aber... nur halt nicht im Firefox... ich verzweifel hier schon gerade... sry :(
     
  10. #9 5. Februar 2009
    mach ma nur im html nur
    <body>

    </body>

    und dann im css
    body{
    margin:0;
    padding:0;
    }

    und mach mal float:left; für die beiden anderen css elemente
     
  11. #10 6. Februar 2009
    noch einfacher wäre es, wenn du deine ultra-geheimen grafiken und quellcodes bereitstellst, um diese "probier mal xxx"-ratespiele zu verhindern. kann ja schließlich auch niemand dein auto reparieren, ohne daran rumzuschrauben.
     
  12. #11 6. Februar 2009
    AW: align / margin Problem - IE: Nein / FF:Ja

    Jo installier dir mal Firebug, damit du siehst welches Containerdiv hier ne Nullsetzung braucht.
     

  13. Videos zum Thema
Die Seite wird geladen...
Similar Threads - align margin Problem
  1. Antworten:
    8
    Aufrufe:
    1.298
  2. Antworten:
    7
    Aufrufe:
    980
  3. negatives Margin im IE

    b-xXx , 17. August 2008 , im Forum: Webentwicklung
    Antworten:
    1
    Aufrufe:
    415
  4. Antworten:
    10
    Aufrufe:
    274