[C/C++] kann mir einer gebührenrechner programmieren?

Dieses Thema im Forum "Programmierung & Entwicklung" wurde erstellt von k-selo, 15. November 2009 .

Schlagworte:
Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 15. November 2009
    kann mir einer gebührenrechner programmieren?

    hallo,
    kann mir einer gebühren rechner programmieren mit excel oder delphi ist egal hauptsache ich brauche diese abfragen:


    wenn EUR 1,00 - EUR 50,00 dann 7% des Verkaufspreises


    wenn EUR 50,01 - EUR 500,00 EUR dann 3,50 zzgl. 4% des Verkaufspreises über EUR 50,00


    wenn EUR 500,01 und höher dann EUR 21,50 zzgl. 2% des Verkaufspreises über EUR 500,00

    10er gibts gerne
     

  2. Anzeige
    Heute: Deals & Sale mit stark reduzierten Angeboten finden.
  3. #2 15. November 2009
    AW: kann mir einer gebührenrechner programmieren?

    Ich weiß zwar nich 100pro ob's das is was du willst aber in Excel könnte die Formel so aussehnen

    Code:
    =WENN(UND(B3>=1;B3<=50);B3*0,07;WENN(UND(B3>=50,01;B3<=500);((B3*0,04)+3,5);((B3*0,02)+21,5)))
    Musst natürlich die Zelle (in meim Bsp. B3) nach deiner Exceltabelle anpassen.

    Viell. hilfts dir ;)
     
  4. #3 15. November 2009
    AW: kann mir einer gebührenrechner programmieren?

    hey das problem ist nur wegen die abfrage ist richtig aber der dann wert ist falsch weil wenn der wert über zwischen 50,01 und 500€ ist dann 4% über 50€ also muss der wert -50 und dann mal 4% +3,50€ gebühren.
     
  5. #4 15. November 2009
    AW: kann mir einer gebührenrechner programmieren?

    kannst du dich mal verständlich ausdrücken? Dann kann man dir vielleicht auch helfen... und ich denke eigeninitiative wird hier auch gerne gesehen. Hier wird wohl keiner deine Hausaufgaben für dich machen.
    Zeig einfach was du schon hast und was genau nicht funktioniert.

    mfg
    Joker
     
  6. #5 15. November 2009
    AW: kann mir einer gebührenrechner programmieren?

    also das ist schon richtig was king2 gepostet hat
    =WENN(UND(B3>=1;B3<=50);B3*0,07;WENN(UND(B3>=50,01;B3<=500);((B3*0,04)+3,5);((B3*0,02)+21,5)))

    nur ich brauche noch eine dann funktion
    wenn EUR 1,00 - EUR 50,00 dann 7% des Verkaufspreises


    wenn EUR 50,01 - EUR 500,00 EUR dann 3,50 zzgl. 4% des Verkaufspreises über EUR 50,00 (bitte beachten der Wert muss -50€ und dann die Differenz *4%+3,5 gerechnet werden)


    wenn EUR 500,01 und höher dann EUR 21,50 zzgl. 2% des Verkaufspreises über EUR 500,00 (bitte beachten der Wert muss -500 und dann die DIfferenz *2%+21,50 gerechnet werden)
     
  7. #6 15. November 2009
    AW: kann mir einer gebührenrechner programmieren?

    Das könnte man jetzt aber auch selbert machen oder!?
    Wenn ichs richtig verstanden einfach -50 bzw -500 bei der Abfrage/Zuweisung machen:

    Code:
    =WENN(UND(B3>=1;B3<=50);B3*0,07;WENN(UND(B3>=50,01;B3<=500);((([B]B3-50[/B])*0,04)+3,5);((([B]B3-500[/B])*0,02)+21,5)))
    
    Beachte das das Verhalten bei unter 1€ und bei über 500€ gleich ist!
    Evtl noch eine Abfrage für den fall das der Betrag unter 1€ liegt hinzufügen.

    Mfg Rushh0ur
     
  8. #7 15. November 2009
    AW: kann mir einer gebührenrechner programmieren?

    Also ich denke das müsste dann so sein
    Code:
    =WENN(UND(B3>=1;B3<=50);B3*0,07;WENN(UND(B3>=50,01;B3<=500);(((B3-50)*0,04)+3,5);((B3-500)*0,02)+21,5))
    
    Aber falls das für schule oder so ist würde ich dir dazu raten dir das lieber selber nochmal alles anzuschauen... so lernst du nämlich null komma gar nix...

    mfg
    Joker
     
  9. #8 15. November 2009
    AW: kann mir einer gebührenrechner programmieren?

    hat geklappt danke an alle :)
     

  10. Videos zum Thema
Die Seite wird geladen...