Diverse Debian fragen und probleme (Apache und Grafikkartentreiber)

Dieses Thema im Forum "Linux & BSD" wurde erstellt von Wigberg, 21. Juli 2010 .

  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 21. Juli 2010
    Servus, Ich habe mir vor langeweile ma auf vmware nen linux aufgesetzt weil ich mich näher mit linux und webservern beschäftigen will.

    Debian alles installiert und soweit konfiguriert, jedoch spackt bei mir der ATI Grafikkartentreiber rum (installiert aber nimmt keine änderungen an etc "aticonfig" nicht ausführbar.

    Aber kommen wir zum wichtigsten problem (mMn.)

    Der Apache2 Webserver ist installiert alles etc. localhost > It Works!
    Aber sobald ich änderungen in der http.conf vornehmen will und den apache restarten will bekomme ich folgendes zu lesen
    Code:
    apache2: bad user name ${APACHE_RUN_USER}
    Habe dann ma gegoogled und gefunden das in der envvars datei sowas wie username und grp stehen muss .. tuts auch
    Code:
    # envvars - default environment variables for apache2ctl
    
    # Since there is no sane way to get the parsed apache2 config in scripts, some
    # settings are defined via environment variables and then used in apache2ctl,
    # /etc/init.d/apache2, /etc/logrotate.d/apache2, etc.
    export APACHE_RUN_USER=www-data
    export APACHE_RUN_GROUP=www-data
    export APACHE_PID_FILE=/var/run/apache2.pid
    Das steht bei mir in der envvars (was laut google auch soweit richtig sei) aber apache2 -k restart sowie apache2 restart funktioniert nicht apache2 restart funktioniert garnicht

    Das bekomme ich unter apache2 restart:
    Code:
    xxxxx:/home/xxxxxx# apache2 restart
    Usage: apache2 [-D name] [-d directory] [-f file]
     [-C "directive"] [-c "directive"]
     [-k start|restart|graceful|graceful-stop|stop]
     [-v] [-V] [-h] [-l] [-L] [-t] [-S] [-X]
    Options:
     -D name : define a name for use in <IfDefine name> directives
     -d directory : specify an alternate initial ServerRoot
     -f file : specify an alternate ServerConfigFile
     -C "directive" : process directive before reading config files
     -c "directive" : process directive after reading config files
     -e level : show startup errors of level (see LogLevel)
     -E file : log startup errors to file
     -v : show version number
     -V : show compile settings
     -h : list available command line options (this page)
     -l : list compiled in modules
     -L : list available configuration directives
     -t -D DUMP_VHOSTS : show parsed settings (currently only vhost settings)
     -S : a synonym for -t -D DUMP_VHOSTS
     -t -D DUMP_MODULES : show all loaded modules 
     -M : a synonym for -t -D DUMP_MODULES
     -t : run syntax check for config files
     -X : debug mode (only one worker, do not detach)
    xxxxxx:/home/xxxxxx# 
    
    Root bin ich angemeldet im terminal habs auch schon mit dem normal user (non root) versucht .. aber scheitert ebenso

    Daten:
    Debian Lenny (sollte aktuell sein)
    läuft auf vmware
     

  2. Anzeige
    Heute: Deals & Sale mit stark reduzierten Angeboten finden.
  3. #2 21. Juli 2010
    AW: Diverse Debian fragen und probleme (Apache und Grafikkartentreiber)

    gibts den user www-data denn? und was willst du unter vmware mit nem ati-treiber? da haste doch ansich nen vmware-adapter, oder wird das bei neueren version durchgeschleift? was sagt denn lspci?...mfg coach

    PS: und was sagt '/etc/init.d/apache2 -k restart'?
     
  4. #3 21. Juli 2010
    AW: Diverse Debian fragen und probleme (Apache und Grafikkartentreiber)

    Funktioniert nicht, bzw. bei meinem Debian Server nicht.
    Ich mach es immer per:
    Bei mir existiert die "http.conf" garnicht, sondern nur die "httpd.conf"
     
  5. #4 21. Juli 2010
    AW: Diverse Debian fragen und probleme (Apache und Grafikkartentreiber)

    das '-k' ist ja auch ein parameter, den das script scheinbar braucht, also nix vonwegen gibts nich^^ (wenns fehler ausgibt, immer her damit xD). und zu meiner eigentlichen frage: gibt es den user www-data denn im system? immerhin will er den dienst unter dessen namen starten...mfg coach=)

    EDIT: und was gibt 'lspci' denn jetzt aus? vmware-graka oder ati-graka?
     
  6. #5 21. Juli 2010
    AW: Diverse Debian fragen und probleme (Apache und Grafikkartentreiber)

    Also bei apache2 -k restart gibt der diese meldung aus
    Code:
    apache2: bad user name ${APACHE_RUN_USER}
    ohne den parameter -k .. gibt der mir nur die aufgelistete hilfe ..

    Wozu ich die graka treiber brauche is einfach erklärt .. ich habe ne höher auflösung drinne aber der gibt mir dann wiederholrate 0 aus ..
    und da wird irgendwie alles größer als ich das will oder gibts ne möglichkeit das zu verkleinern ?

    und zu der http.conf .. handelt sich um nen schreibfehler meinerseits ^^ habs D vergessen

    zu den lspci .. was is das und wo muss ich das nachschauen ? :D
    und zu dem user ding .. ich meine ich hätt den gesehen aber ich schaue jetzt mal nach obs den gibt .. sonst erstell ich den einfach

    /edit

    xxxxxx:/home/xxxxxx# adduser www-data
    adduser: Der Benutzer »www-data« existiert bereits.

    Dementsprechend muss es diesen user geben korrekt ? aber sobald ich auf den wechseln will (su www-data) wechsel ich auf den sobald ich nen cmd eingebe .. macht der voll automatisch exit und fliege aus dem user raus
     
  7. #6 21. Juli 2010
    AW: Diverse Debian fragen und probleme (Apache und Grafikkartentreiber)

    beim apache und dem user hab ich kp, aber bei der wiederholrate 0 kann ich dir helfen: das ist normal in ner vmware-vm(!). dass alles größer aussieht wird an den dpi liegen, musste da mal rumschrauben. wenn du mit root-rechten lspci ausführst (könnte auch nen extra paket, pciutils oder so, gewesen sein), führt es dir alle möglichen angeschlossenen geräte auf (es gibt auch z.b. lsusb). da würde der dir dann entweder ne ati-graka (unwahrscheinlich) oder ne vmware-graka anzeigen...mfg coach
     
  8. #7 23. Juli 2010
    AW: Diverse Debian fragen und probleme (Apache und Grafikkartentreiber)

    Also ich habe nun überall gestöbert und gegoogled ..

    ich kriege die wiederholrate einfach nicht höher und find keine einstellungen wegen der grafikkarte


    und zu dem apache problem .. ich denke ich werd den deinstallieren und neu installieren ..
     
  9. #8 23. Juli 2010
    AW: Diverse Debian fragen und probleme (Apache und Grafikkartentreiber)

    Hast du schon die VMWare-Guest-Additions installiert?
     
  10. #9 23. Juli 2010
    AW: Diverse Debian fragen und probleme (Apache und Grafikkartentreiber)

    Ich denke schon also ich habe alles installier was mit vmware zutun hat ..
    jedoch die tools (die direkt nach der OS install installiert werden sollten) die wollen nicht ... der meint irgendwas der kann die "cd" nicht lesen

    ich werd nachher mal die genaue fehler meldung posten

    ps: apache neu install und veränderung der envvars brachte es auch nicht ..

    hat jmd ne idee wie ich die seperat unter einem anderen user ohne envvars starten kann ?

    ok vergesst was ich über den apache gesagt hab ^^ ich sollte lesen lernen .. restart funzt .. aber nur bei direkter ansteuerung =)
    also apache problem GELÖST
    Grafikproblem besteht nach vor vor

    Bw soweit raus
     

  11. Videos zum Thema
Die Seite wird geladen...
Similar Threads - Diverse Debian fragen
  1. Antworten:
    7
    Aufrufe:
    1.984
  2. Antworten:
    2
    Aufrufe:
    1.076
  3. Antworten:
    12
    Aufrufe:
    789
  4. Antworten:
    10
    Aufrufe:
    1.377
  5. Antworten:
    4
    Aufrufe:
    363