Festplatten unter Linux / KDE

Dieses Thema im Forum "Linux & BSD" wurde erstellt von kama, 4. Dezember 2006 .

Schlagworte:
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 4. Dezember 2006
    Hallo RRler,

    ich habe folgendes problem....
    ich habe ne externe usb platte angeschlossen.. unter den hardware eigenschaften wird mir
    des verzeichnis als /dev/sdb angegeben.... wenn ich in dieses verzeichnis geh find ich die datei,
    allerdings lässt sich die nicht öffnen...
    wie kann ich des öffnen?

    thx schonmal

    greetz kama

    PS: nein die platte wird nicht unter dem "arbeitsplatz" also "my computer" angezeigt...
     

  2. Anzeige
  3. #2 4. Dezember 2006
    AW: Festplatten unter Linux / KDE

    bevor du eine platte benutzen kannst musst du sie in einem verzeichnis mounten. Alle deine Festplatten werden gemountet schau mal in /etc/fstab nach ;)

    normalerweise kannst du eine festlpallte normal mounten indem du ein verzeichnis zunächst erstellt, also z.b. /mnt/usb-platte
    und dann über die konsole deine Festplatte /dev/sdb mountest. Diese Festplatte ist warscheinlich formatiert und ich denke mal es ist eine große Partition. dann kannst du die platte mit
    Code:
    mount /dev/sdb[B]1[/B] /mnt/usb-platte
    mounten. Normalerweise geht das, ausser wenn die Platte z.b. ein Fat-32 oder NTFS Dateisystem hat, bei fat kannst du in der fstab einen eintrag machen so mounte ich z.b. meinen usb-stick
    Code:
    /dev/sda1 /mnt/usb vfat noauto,user,umask=0000
    und mit
    Code:
    mount /mnt/usb
    den stick mounten.
    solltest du probleme haben, gibt dir Gentoo (ich weiß jetzt nicht welche distri du hast) eine schöne Anleitung zum mounten von MS Dateisystemen http://de.gentoo-wiki.com/MS_Dateisysteme_mounten

    mit
    Code:
    df -h
    werden dir deine gemounteten Platten angezeigt also z.b.
    Code:
    schiene@gentoo ~ $ df -h
    Filesystem Size Used Avail Use% Mounted on
    /dev/hda10 1.9G 229M 1.6G 13% /
    udev 253M 256K 252M 1% /dev
    /dev/hda7 380M 14M 346M 4% /tmp
    /dev/hda8 973M 313M 611M 34% /opt
    /dev/hda9 53G 41G 9.7G 81% /home
    /dev/hda11 13G 5.1G 7.2G 42% /usr
    /dev/hda12 14G 371M 13G 3% /var
    /dev/hda1 4.7G 2.6G 2.1G 55% /mnt/windows
    /dev/hda2 30G 2.0G 26G 7% /mnt/appz
    /dev/hda3 30G 20G 8.4G 71% /mnt/coding
    shm 253M 0 253M 0% /dev/shm

    greetz schiene
     
  4. #3 4. Dezember 2006
    AW: Festplatten unter Linux / KDE

    bei mir kommt jetz:

    mount: /dev/sdb: can't read superblock
     
  5. #4 4. Dezember 2006
    AW: Festplatten unter Linux / KDE

    was für ein filesystem ist denn auf der platte? Ist es eine große Partition?
     
  6. #5 4. Dezember 2006
    AW: Festplatten unter Linux / KDE

    NTFS oder FAT ... weiss ich nichmehr genau

    die pladde is 250 giga groß...
     
  7. #6 4. Dezember 2006
    AW: Festplatten unter Linux / KDE

    ja ob nfts oder fat issen kleiner feiner unterschied :p
    fat kannste einfach so mounten (als root):

    /dev/hda1 /mnt/windows vfat auto,rw,umask=000 0 0

    nfts is wieder ne andre sache also wär ma ganz gut das zu wissen und es wär mal ganz hilfreich zu wissen was für eine distri du hast... vllt solltest du einfach mal in der anleitung deiner distri schaun , hast du zufällig suse? also da gibt bestimmt gute einleitungen in das thema festplatten mounten sonst wie gesagt für gentoo :p ist das ganze schön erklärt ;)
     
  8. #7 4. Dezember 2006
    AW: Festplatten unter Linux / KDE

    Suse 10.1, ja gentoo hab icha uch schon geschaut aber ich bekomm dieses captivate nich installiert... muss dazusagen das ich nen absoluter linux noob bin...


    unter fstab wird angezeigt :.

    so bin jetz noch weiter gekommen:

     
  9. #8 4. Dezember 2006
    AW: Festplatten unter Linux / KDE

    Code:
    /dev/sda7 / reiserfs acl,user_xattr 1 1
    /dev/sda8 /home reiserfs acl,user_xattr 1 2
    [B]/dev/hda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
    /dev/hda2 /windows/D ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
    /dev/sda1 /windows/E ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
    /dev/sda5 /windows/F ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0[/B]
    /dev/sda6 swap swap defaults 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    debugfs /sys/kernel/debug debugfs noauto 0 0
    usbfs /proc/bus/usb usbfs noauto 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    Da siehst du wie man ntfs platten mountest, da brauchst du kein Captive, das ist der Weg für Gentoo system in deinem Fall ist es einfacher.
    mach einfach einen neuen Eintrag in die /etc/fstab und zwar
    Code:
    /dev/sdb1 [B]/mnt/usb-platte[/B] ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
    dann müsstest du die Platte einfach mit einem mount /mnt/usb-platte mounten können, aber als root mounten! Ich denke einfach du hast eine NTFS platte ne. ansonsten wenns halt ne fat ist kannst du das anwenden was ich schon zuvor geschrieben hatte
     
  10. #9 5. Dezember 2006
    AW: Festplatten unter Linux / KDE

    immermal wieder ne neue errormeldung:


    Code:
    [mntent]: warning: no final newline at the end of /etc/fstab
    mount: wrong fs type, bad option, bad superblock on /dev/sdb,
     missing codepage or other error
     In some cases useful info is found in syslog - try
     dmesg | tail or so
    
     
  11. #10 5. Dezember 2006
    AW: Festplatten unter Linux / KDE

    Die newline Fehlermeldung kommt daher, dass am ender der Datei /etc/fstab keine neue Zeile angefangen ist, mmach eine eine neue leere Zeile am Ende der /ect/fstab, dann verschwindet der Fehler.

    Zu dem andern bist du dir sicher, dass es eine NTFS ist? sonst schau mal was dutziman dir geraten hat
     
  12. #11 6. Dezember 2006
    AW: Festplatten unter Linux / KDE

    Hatte heute das fast gleiche Problem un habs zum glück gelöst bekommen.

    als erstes wenn du auf die NTFS Platte schreiben möchtest nen Treiber installieren ich selber benutze ntfs-3g ist recht schnell und auf jedenfall schneller als captive.

    und dann in der fstab folgendes einfügen:

    /dev/sdb1 /media/Musik ntfs-3g
    silent,umask=0,locale=en_US.utf8,no_def_opts,allow_other 0 0

    Wobei sdb1 und Musik variabel sind
    den ordner in /media musst du vorher anlegen.

    danach konsole und als root einloggen geht bei mir unter ubuntu mit su
    und dann einfach umount -a

    und dann mount -a

    und wenn du alles richtig gemacht hast solltest du nun auf die platte zugreifen können und schreiben auch noch dazu.

    hoffe konnte helfen
     
  13. #12 6. Dezember 2006
    AW: Festplatten unter Linux / KDE

    Kann gefährlich sein, denn mit manchen Kernelversionen werden damit auch proc, /, sys, dev, usw. geumountet.
    "mount /dev/sdb1" reicht völlig.
     
  14. #13 6. Dezember 2006
    AW: Festplatten unter Linux / KDE

    ok wie gesagt bei mir war es die einzige möglichkeit damit ichs ans laufen bekommen habe.
    bin jetzt nicht der super linux kenner deswegen hab ich mir dabei nichts gedacht.

    aber du hast recht es könnte gefährlich sein.
     
  15. #14 17. Dezember 2006
    AW: Festplatten unter Linux / KDE

    kämpfe im moment mit einem ähnlichen problem, nur fängt es bei mir schon etwas früher an... wenn ich die fstab ändern will sagt er mir ich habe entweder die rechte nicht oder die platte ist voll. das problem is nur ich hab keine ahnung wie ich mich als root anmelde. kann mich über die normal benutzernameldung nur mit 2 accs anmelden (die ich selbst gemacht habe) die haben auch beide root rechte, aber damit gehts nit :/ brauchen die noch andere rechte oder wie kann ich mich als root anmelden? benutzte die neuste kubuntu distro (müsste 6.10 sein oder so).
     
  16. #15 17. Dezember 2006
    AW: Festplatten unter Linux / KDE

    Der graphische Login als Root ist im X-Server standartmäßig deaktiviert.
    Entweder machst du ein Terminalfenster auf und machst dich mit dem Befehl "su" in Kombination mit dem Root-Password
    oder du wechselst mit Strg+Alt+F1 in den Textmodus und meldest dich dort als Root an. Mit Strg+Alt+F kommst du dann wieder zum X-Server zurück.
     
  17. #16 17. Dezember 2006
    AW: Festplatten unter Linux / KDE

    hey, wenn du mir jetzt noch sagen kannst wie ich als root in ne grafische oberfläche komm dürfte mein problem hoffentlich geklärt sein^^
     
  18. #17 17. Dezember 2006
    AW: Festplatten unter Linux / KDE

    als root inner grafische oberfläche? tus nich! viel zu unsicher, lieber mit alt+f6 wieder zum login-screen wechseln^^...mfg coach
     
  19. #18 18. Dezember 2006
    AW: Festplatten unter Linux / KDE

    ja aber wie soll ich dann die fstab ändern?
     
  20. #19 18. Dezember 2006
    AW: Festplatten unter Linux / KDE

    im terminal selbverständlich.
    terminal öffnen
    Code:
    sudo nano -w /etc/fstab
    ggf nano nachinstallieren per
    Code:
    sudo apt-get install nano
     
  21. #20 18. Dezember 2006
    AW: Festplatten unter Linux / KDE

    Geht auch mit dem mitgelieferten Vim.
    Code:
    vi /etc/fstab
    Dann mit "i" in den Schreibmodus, ändern, was man zu ändern gedenkt,
    dann mit Escape aus dem Schreibmodus raus, ":qw" eintippen und Enter drücken ;)
     
  22. #21 22. Dezember 2006
    AW: Festplatten unter Linux / KDE

    danke für eure hilfe hat jetzt geklappt, sry bin noch absoluter anfänger ;)
     
  23. #22 3. Januar 2007
    Zuletzt von einem Moderator bearbeitet: 15. April 2017
    AW: Festplatten unter Linux / KDE

    bei mir geht immernoch nix ... ich verweise mal hierhin : Ich bin ein Link
     

  24. Videos zum Thema
Die Seite wird geladen...
Similar Threads - Festplatten Linux KDE
  1. Antworten:
    2
    Aufrufe:
    1.005
  2. Antworten:
    1
    Aufrufe:
    457
  3. Antworten:
    0
    Aufrufe:
    1.846
  4. Antworten:
    5
    Aufrufe:
    322
  5. Antworten:
    7
    Aufrufe:
    374