Frage zum Zeichensatz "Mysql"

Dieses Thema im Forum "Linux & BSD" wurde erstellt von Gimli_q, 20. Mai 2007 .

Schlagworte:
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 20. Mai 2007
    Leute, ich hab mir auf meinem V-Server, PHP5, mysql 5.1 und phpmyadmin installiert. Warum werden die ganzen ü,ä,ö's nicht angezeigt? Ich hab im phpmyAdmin den Zeichensatz UTF8_general_ci gewählt.

    Weis da jemand mehr?
     

  2. Anzeige
    Dealz: stark reduzierte Angebote finden.
  3. #2 20. Mai 2007
    AW: Frage zum Zeichensatz "Mysql"

    Führ mal ein
    SHOW VARIABLES LIKE '%character%'; aus und poste mal hier die ausgabe.
     
  4. #3 20. Mai 2007
    AW: Frage zum Zeichensatz "Mysql"

    character_set_client utf8
    character_set_connection latin7
    character_set_database latin1
    character_set_filesystem binary
    character_set_results utf8
    character_set_server latin1
    character_set_system utf8
    character_sets_dir /usr/share/mysql/charsets/
     
  5. #4 20. Mai 2007
    AW: Frage zum Zeichensatz "Mysql"

    Ok, dann mach mal ein
    SET NAMES utf8;
    Dann drop'ste mal die DB und erstellst sie neu.

    Wäre auch gut zu wissen wo die umlaute nicht angezeigt werden.
    Beachte, das wenn du funktionen wie htmlspecialchars() oder htmlentities() nutz, du extra den utf8 Zeichensatz angeben musst!
     
  6. #5 21. Mai 2007
    AW: Frage zum Zeichensatz "Mysql"

    Hi

    Auf meinem Webspace musste ich in die Konfigurationsdatei den Befehl

    mysql_query("SET NAMES utf8;");

    eintragen, damit er bei jedem Seitenaufruf ausgeführt wird. Nur einmaliges Aufrufen des Befehls nützte bei mir nichts.

    Hier ein gutes Tutorial, welches dir vielleicht weiterhilft:

    UTF-8 und die Entity


    Mfg Bl0bb
     

  7. Videos zum Thema
Die Seite wird geladen...