Htaccess Probleme auf Linux Server mit lampp

Dieses Thema im Forum "Hosting & Server" wurde erstellt von elf4, 6. Juli 2009 .

  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 6. Juli 2009
    Grüßt Euch,

    ich habe ein kleines aber nervendes Probleme.

    Auf einen Linux Debian-50-lenny-64-minimal der mit lampp in der Standardkonfiguration läuft habe ich eine .htaccess mit .htpasswd erstellt. Wenn ich in das schützende Verzeichnis über den Http Browser komme wird wie erwünscht nach einen User & Password gefragt.

    Doch dann gibt der Server ein internal Error 500 aus mit folgenden Statement:

    Code:
    [B]Serverfehler![/B]
    
    Die Anfrage kann nicht beantwortet werden, da im Server ein interner Fehler aufgetreten ist. Der Server ist entweder überlastet oder ein Fehler in einem CGI-Skript ist aufgetreten.
    
    Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
    Error 500
    
    [I]Mon 06 Jul 2009 11:08:45 AM CEST
    Apache/2.2.11 (Unix) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8k PHP/5.2.9 mod_apreq2-20051231/2.6.0 mod_perl/2.0.4 Perl/v5.10.0[/I] 
    Habe natürlich gleich gegoogled konnte aber keine Lösung für mein Probleme finden. Kennt jemand die Problematik und weiss Abhilfe?
     

  2. Anzeige
    Dealz: stark reduzierte Angebote finden.
  3. #2 6. Juli 2009
    AW: Htaccess Probleme auf Linux Server mit lampp

    Poste doch mal die .htaccess und die .htpasswd. Kannst den Inhalt ja ändern.

    Ich glaube aber das du das:

    Code:
    <Limit GET>
    require valid-user
    </Limit>
    und/oder das:
    Code:
    AuthGroupFile /dev/null
    in der .htaccess stehen hast.

    Lösch das mal, so war es damals bei mir.
     
  4. #3 6. Juli 2009
    AW: Htaccess Probleme auf Linux Server mit lampp

    Ohne die beiden Zeilen funktioniert der Zugriff auf das Verzeichnis. Dann wird aber keine Passwordabfrage mehr gestellt.


    PHP:
    AuthUserFile  /var/ www / ws / defcore / board /. htpasswd
    # AuthGroupFile /dev/null
    AuthName  "Defcore Security Area"
    AuthType Basic
    # <Limit GET>
    # require user
    # </Limit>
     
  5. #4 6. Juli 2009
    AW: Htaccess Probleme auf Linux Server mit lampp

    Die Zeile mit AuthGroupFile kannst sowieso weglassen wenn du da /dev/null angibst.
    Anstelle von <LIMIT GET> würd ich <LIMIT GET POST> machen. Ganz sicher kein Fehler.

    In weiterer Folge hast du tatsächlich wie schon oben genannt einen Syntax-Fehler.
    "require user" funktioniert nur wenn man dann explizit einen User angibt also zb
    require user admin

    In deinem Fall wenn du "irgendeinen" User der .htpasswd zulassen willst, is ein das notwendig:
    require valid-user

    Sollte es dann immer noch nicht funktionieren, sieh dir doch einfach die Fehlerausgabe des Apaches an:
    tail -f /var/log/apache2/error.log

    Das erübrigt jede weitere Spekulation über die Fehlerursache...
     
  6. #5 9. Juli 2009
    AW: Htaccess Probleme auf Linux Server mit lampp

    PHP:
    AuthUserFile  /var/ www / ws / defcore / board /. htpasswd
    AuthName 
    "Defcore Security Area"
    AuthType Basic
    require  valid - user
    die .htpasswd solltest aus sicherheitsgründen wenn möglich woanders lagern, wo man von außen übern apache nicht rankommt.
    Desweiterne gibts verschiedene hashalgorithmen, die für die passes in der htpasswd benutzt werden können. vielleicht ist da irgendwas im eimer.
    versuch mal Htpasswd Generator - Create a htpasswd password

    ansonsten auf jedenfall wie gesagt mal in fehlerlog schaun und ggf. hier posten
     
  7. #6 9. Juli 2009
    AW: Htaccess Probleme auf Linux Server mit lampp

    Hallo,

    mal nach den Dateirechten bzw Verzeichnissrechte gesehen, das könnte der Fehler sein.

    MfG

    Steffen Becker
    Thüringer Webhosting
     

  8. Videos zum Thema
Die Seite wird geladen...
Similar Threads - Htaccess Probleme Linux
  1. Antworten:
    2
    Aufrufe:
    1.508
  2. [htaccess] rewrite www.

    onip , 10. März 2014 , im Forum: Webentwicklung
    Antworten:
    3
    Aufrufe:
    853
  3. Antworten:
    2
    Aufrufe:
    1.362
  4. Antworten:
    3
    Aufrufe:
    988
  5. Antworten:
    0
    Aufrufe:
    396
  • Annonce

  • Annonce