Mounten bei ner Festplatte

Dieses Thema im Forum "Linux & BSD" wurde erstellt von Mr_MeYa, 16. Dezember 2005 .

Schlagworte:
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 16. Dezember 2005
    Ich habe Debian 3.1 Sarge.

    Ich habe getsern meine 40GB NTFS Festplatte Formatiert und nun auf Linux umformatiert. Nun will ich das ding mounten, da spuckt er mir das aus:

    Code:
    mount: wrong fs type, bad option, bad superblock on /dev/hdb1,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so
    Please check that the disk is entered correctly.
    Der syslog sagt mir halt das es keine NTFS Platte mehr ist, aber was schriebe ich jetzt in die fstab Datei rein um das der die mountet und das ich darauf schreiben kann?


    Thx & Mfg
    Mr_MeYa
     

  2. Anzeige
  3. #2 16. Dezember 2005
    Hi,

    soweit ich weiss, sind nur FAT32-HDDs beschreibbar. Dazu formatierst du deinen Festplattentyp zu FAT32 und schreibst dann in die /etc/fstab :

    Code:
    /dev/hda1 /Windows/hda1 vfat uid=1000,gid=1000 0 0
    
    /dev/hda1 = deine Windows-Platte
    /Windows/hda1 = Dorthin mountest du es (Der ordner muss existieren btw)
    vfat = Name für FAT32-HDD-Typ
    uid=1000,gid=1000= findest du per "id" raus, vlt verändern
    rest brauchste dir keine sorgen zu machen

    Mfg,

    Kolazomai
     
  4. #3 16. Dezember 2005
    Also... ich glaube nicht das man nur auf FAT32 schriben kann.. und vorallem, wie soll ich denn bitte unter cfdisk die Platte auf FAT32 umformatieren...
     
  5. #4 16. Dezember 2005
    Oehm,

    Ich denke schon, dass man nur auf FAT32 schreiben kann. Kannst ja mal ausprobieren. Das vfat oben musste halt durch ntfs ersetzen Oo'.

    Irgendwo hier im Board ist auch noch ein Tutorial dazu, kannste ja mal suchen.

    Ich denke nicht, dass du darauf schreiben können wirst.

    Mfg,

    Kolazomai
     
  6. #5 17. Dezember 2005
    nur fat32 is zu linux voll kompatibel. NTFS nicht. es gibt zwar beschränkten schreibsupport für linux, aber der beschränkt sich (kernelseitig) nur darauf dateien so zu verändern, dsas sich deren größe nicht ändert. mit anderen worten nutzlos.

    es gibt außerdem das captive NTFS driver projekt, allerdings sind diese treiber extrem instabil und langsam, deshalb nicht zu empfehlen.

    du musst dich, wenn du deine platten nicht auf ext3 oder dergleichen umformatieren kannst wohl mit platte lesen begnügen
     
  7. #6 17. Dezember 2005
    Code:
    mount: wrong fs type, bad option, bad superblock on /dev/hdb,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so
    Please check that the disk is entered correctly.
    Also ich habe meine Fessi nun auf FAT32 umformatiert... klappte alles nicht... warum kann ich idie Platte nicht auf Linux lassen... naja...
     
  8. #7 17. Dezember 2005
    1. Moechtest du auf diese Festplatte eine Linuxdistribution installieren?
    -- (Ja)
    Dann formatiere diese Festplatte z.b. reiserfs oder ext3 (was die unter Linux gaengigsten Dateisysteme sind).
    Jedoch solltest du die ersteinmal Partitionieren:
    Code:
    cfdisk /dev/hda
    hda1 = /
    hda2 = /home
    hda3 = swap
    (Dies sind nur Beispiele das musst du natuerlich nicht so machen)

    Nun musst man die Festplatte auch formatieren, dies geht so:
    Code:
    mkreiserfs /dev/hda1
    oder fuer ext3:
    Code:
    mke2fs -j /dev/hda1
    und dann fuer swap:
    Code:
    mkswap /dev/hda3
    -- (nein) / (ich will sie nur mounten um darauf zu schreiben)
    Nun dann solltest du sie natuerlich ebenso ersteinmal (siehe oben) Partitionieren,
    und dann Formatieren, das kommt natuerlich darauf an ob du sie nur fuer das "arbeiten" unter Linux benutzen willst oder auch von Windows darauf zugreifen.
    Wenn du von Windows auch darauf zugreifen willst um z.b. Daten zu sharen, formatierst du sie "FAT32" wenn nicht kannst du eine der oberen Dateisysteme auswaehlen.

    Wie das geht ganz einfach:
    Code:
    mkdosfs -F 32 /dev/hdX
    2. Hast du das alles oben so gemacht wie du es haben wolltest und es geht immernochnicht?
    -- (ja)
    Dann melde dich nochmal :p
    -- (nein)
    Dann sollte es jetzt ja gehen nachdem du es so wie oben gemacht hast :p
     
  9. #8 17. Dezember 2005
    du kannst auch beim mounten mal "-t auto" probieren. damit soll das dabeisystem automatisch erkannt werden. könnte ja funzen.
     
  10. #9 17. Dezember 2005
    hat gefunzt, also nun kannich unter root daten schriebn aber unter meinem eigentlichm Benutzernamen kann ich nur lesen, was soll ich nun in die fstab reinschriebn!

    Thx
    Mr_MeYa
     
  11. #10 17. Dezember 2005
    werte entsprechend abändern. das entscheidende sind die uid und gid.
     

  12. Videos zum Thema
Die Seite wird geladen...