Mouseover-problem!

Dieses Thema im Forum "Webentwicklung" wurde erstellt von Funky, 11. Juli 2007 .

  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 11. Juli 2007
    Tach!

    Ganz kurz: hab mir mit PS eine HP erstellt, geslicet und für web gespeichert! Jetzt verwende ich erfolgreich den onmouseover befehl, kennt ja denke jeder! Aber der Internet Explorer macht da automatisch immer einen Rahmen um das Bild wenn ich das als link benutze, sprich <a href="blabla".....mouseover effekt....</a>. Da verschiebts mir dann das ganze layout, da der Rahmen total stört! Hat da jemand vllt. nen befehl wie ich das unterdrücken kann?? (Bei Opera funktionierts perfekt, warum können nicht alle opera nehmen ;) )

    danke schonma!! Bw is klar!

    Ach ja, google erfolglos benutzt!
     

  2. Anzeige
    Dealz: stark reduzierte Angebote finden.
  3. #2 11. Juli 2007
    AW: Mouseover-problem!

    Musst den Border auf 0 setzten!

    Welches Prog benutzt du?
     
  4. #3 11. Juli 2007
    AW: Mouseover-problem!

    Border ist auf null! Da gabs einen speziellen befehl, weiss den aber ums verrecken nicht mehr!

    Ich benutze kein prog, programmiere per hand :)

    Danke, aber suche immer noch!

    MfG, Funky
     
  5. #4 11. Juli 2007
    AW: Mouseover-problem!

    quelltext wär von vorteil...

    *glaskugel such*
     
  6. #5 11. Juli 2007
    AW: Mouseover-problem!

    Benutzt du den IE? Also prinzipiell wird irgendwie immer einen Rahmen um das eingebette Bild zur MArkierung des Links gezogen, sobald du diesen Rahmen auf border 0 setzt sollte es passen! Ist weiterhin trotzdem ein rahmen drunter wird es was anderes sein und wir brauhcn den quelltext.
     
  7. #6 11. Juli 2007
    AW: Mouseover-problem!

    Das ist der Quelltext, des besagten links.

    Hoffe mir kann da jemand helfen!

    Ach ja, was ich noch dazusagen muss, das macht nur der Internet Explorer, bei Opera sieht alles gut aus!
    Ich glaube das ist wichtig!
     
  8. #7 11. Juli 2007
    AW: Mouseover-problem!

    [vermut]benutz mal für den img-tag eine einzige zeile[/vermut]
     
  9. #8 11. Juli 2007
    AW: Mouseover-problem!

    Macht keinen Unterschied!

    Aber danke für die Idee!

    Bitteeee, hatte das Problem noch nie jemand?? Würde mich stark wundern!

    Ich will weitermachen, kann mir nicht jemand helfen??
     
  10. #9 11. Juli 2007
    AW: Mouseover-problem!

    Vielleicht liegt der Fehler bei table, tr oder vllt im css?? Könnte ja sein.
    Also schau nach vielleicht ist der Fehler da.
     
  11. #10 11. Juli 2007
    AW: Mouseover-problem!

    Nee, das liegt nicht am code. Der stimmt, der Fehler ist ja auch nur bei IE (firefox weiss ich nicht).

    CSS benutz ich nicht, bis jetzt nur html, später php.

    Also seh ich das richtig wenn das hier auch keiner weiss? Ich kann mir gar nicht vorstellen dass der Fehler so exotisch ist!

    Kennt vllt. jemand ein gutes forum in dem man solche Fragen stellen kann (html-forum???)

    Danke für die Antworten, falls doch noch jemand ne idee hat, her damit ;)

    MfG, Funky
     
  12. #11 11. Juli 2007
    AW: Mouseover-problem!

    Also, da du nach xhtml standard schreibst, ist das img Tag leer und muss daher ordentlich geschlossen werden.
    2. Da der Fehler nur im IE auftritt, hab ich weiterhin die vermutung, dass das schreiben des links in einer Zeile Abhilfe schafft.
    3. Hast du a img versucht mal eine border zu geben?
     
  13. #12 11. Juli 2007
    AW: Mouseover-problem!

    Versteh nicht ganz was du damit meinst, sry

    Habs alles in eine Zeile geschrieben, bringt aba leider nix

    Aber wenn ich versuch dem Bild einen Rand zu geben verschiebt sich doch alles noch mehr ?(


    So, hab jetzt nochma ein bild von besagtem Fehler hochgeladen:
    Bild=down!
     
  14. #13 12. Juli 2007
    AW: Mouseover-problem!

    du hast in deiner tabelle zu viele leerzeichen :)
    mein tipp: kein einziges leerzeichen/zeilenumbruch zwischen <td> und </td>, evtl. auch nich zwischen <tr> und </tr>
    also das ganze bild mit link und allem in eine zeile
    sieht nicht besonders schön aus, funktioniert aber ;)
     

  15. Videos zum Thema
Die Seite wird geladen...
Similar Threads - Mouseover problem
  1. Antworten:
    1
    Aufrufe:
    630
  2. Antworten:
    13
    Aufrufe:
    481
  3. mouseover problem

    cain , 1. April 2007 , im Forum: Webentwicklung
    Antworten:
    10
    Aufrufe:
    323
  4. Antworten:
    2
    Aufrufe:
    199
  5. Antworten:
    0
    Aufrufe:
    314
  • Annonce

  • Annonce