[.NET] Webbrowser nimmt HTML-Code nicht an?

Dieses Thema im Forum "Programmierung & Entwicklung" wurde erstellt von whenyouDIE, 16. Februar 2010 .

Schlagworte:
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 16. Februar 2010
    Webbrowser nimmt HTML-Code nicht an?

    Hallo RR'ler,

    hab n Problem mit meinem Webbrowser in der Visual Studio 2008 .net umgebung, und zwar, gebe ich dem Webbrowser, HTML Code, den er meistens auch anzeigt, so nun ist es aber so, wenn ich meine Application minimiere, und sie dann wieder maximiere vom Trayicon herraus, gebe ich ihm wieder neuen HTML Code, diesen nimmt er aber nicht an und zeigt nur ein weißes Fenster an, weiß jemand wie ich dieses Problem beheben kann?

    hab es schon mit Refreshes von der Gesammten vorm und für den Webbrowser übernommen aber das hat leider nichts gebracht, genauso wie Application.DoEvents.

    Hoffe mal jemand von euch hat ne Lösung?

    mfg
    whenyou

    edit:
    den Htmlcode übergebe ich mit:

    Webbrowser.DocumentText = "HtmlCode"
     
  2. Heute Deals & Sale mit stark reduzierten Preisen: Jetzt alle ⚡ Angebote finden.


  3. #2 16. Februar 2010
    AW: Webbrowser nimmt HTML-Code nicht an?

    Du könntest den WebBrowser disposen und nen neuen erstellen. Das geht aber sicher auch anders. Wenn du den Code postest kann ich vll ehr helfen.
     
  4. #3 16. Februar 2010
    AW: Webbrowser nimmt HTML-Code nicht an?

    Webbrowser disposen würde ich ungern machen,
    habe nun aber nach 3 stunden festgestellt, das es anscheinend erst geht -> also dem Browser den HTML-Code zu geben, wenn die Form wircklich aktiv ist, und ich dann die form erst hochladen lasse, und dann mir nen Thread aufmache, der es dann gemerkt hat, das die Form nun aktiv ist, dann funktioniert es, aber die methode ist echt ziemlich kake.

    Wenn ich den HTML-Code zuerst übergebe (bevor die Form aktive ist), funktioniert es nicht (also zumindest bei meinen ca 20 test versuchen?)

    Code:
    
    HTMLCodeMessage = tempText & HTMLCodeMessage
    System.Threading.Thread.Sleep(10)
    
    web_Browser.DocumentText = (StartHtmlCodeChat & HTMLCodeMessage & EndHtmlCode).ToString
    
    mehr passiert da nicht hole mir einfach den HTML COde, mache nen sleep und übergebe mir den Code zum .documenttext

    mfg
     

  5. Videos zum Thema
    Video Script
Die Seite wird geladen...

Ähnliche Themen mit den Stichworten: NET Webbrowser nimmt

  1. Antworten:
    0
    Aufrufe:
    456
  2. [.NET] Webbrowser bringt Fehler!
    MasterJulian, 21. Dezember 2008 , im Forum: Programmierung & Entwicklung
    Antworten:
    5
    Aufrufe:
    430
  3. Antworten:
    5
    Aufrufe:
    896
  4. Antworten:
    2
    Aufrufe:
    541
  5. Antworten:
    0
    Aufrufe:
    4.964