[PHP] Anmeldungsfehler in einem Forum

Dieses Thema im Forum "Webentwicklung" wurde erstellt von heiko12345, 16. Februar 2009 .

Schlagworte:
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 16. Februar 2009
    Anmeldungsfehler in einem Forum

    Also ich betreibe ja ein Forum.
    Und in diesem Forum gab es unten einen Quick-Login Bereich, dieser war aber nur im Index zu sehen, wie hier.: Foren-Übersicht • phpBB.de (einfach mal in ein subforum klicken und da ist dann kein Quick-Login mehr zu sehen)

    Ich dieses Quick-Login Dingens nun bei mir auf der Seite aber jederzeit verfügbar gemacht.


    Nur anmelden kann ich mich tatsächlich nur in der Foren Übersicht.
    Wenn ich das versuche während ich im Forum bin oder Topics anschau etc. funktioniert garnichts.

    Wie könnte ich das beheben?


    [edit] respekt, ihr seid hier netter und schneller mit antworten als in einigen fachspezifischen foren.
     

  2. Anzeige
  3. #2 16. Februar 2009
    AW: Anmeldungsfehler in einem Forum

    Hi,

    Codeteil im Übersichtsbereich:
    PHP:
    < form  class= "headerspace"  action = "./ucp.php?mode=login"  method = "post" >
    Codeteil in Unterforen:
    PHP:
    < form  class= "headerspace"  action = ""  method = "post" >
    Was fehlt? Genau, die action. Also einfach gesagt, jene Datei, die beim Klicken auf "Anmelden" ausgeführt wird.
     
  4. #3 16. Februar 2009
    AW: Anmeldungsfehler in einem Forum

    das kapier ich aber nicht, weil es wird in jedem fall eine overall_header eingebunden, und in dieser befindet sich der login teil.....

    Code:
    <!-- IF not S_USER_LOGGED_IN and not S_IS_BOT -->
     <form method="post" action="{S_LOGIN_ACTION}" class="headerspace">
    
    <div id="bname"> 
     {L_USERNAME}: </div>
    <div id="inputname"><input type="text" name="username" id="username" size="10" class="inputbox" title="{L_USERNAME}" /></div>
    
    <div id="bpasswort"> 
     {L_PASSWORD}: </div>
    <div id="inputpasswort"><input type="password" name="password" id="password" size="10" class="inputbox" title="{L_PASSWORD}" /></div>
    
    <div id="autologins"> 
     <!-- IF S_AUTOLOGIN_ENABLED -->
     <input type="checkbox" name="autologin" id="autologin" />Autologin
     <!-- ENDIF --></div>
    <div id="loginbutton">
     <input type="submit" name="login" value="{L_LOGIN}" class="button2" />
    </div> 
     </form>
    das ist der teil von mir in der overall_header.html

    p.s. man kann aber auch kein häkchen bei autologin setzen ausser auf dem forenindex.
     

  5. Videos zum Thema
Die Seite wird geladen...