PHP, SuSE und useradd und userdel

Dieses Thema im Forum "Linux & BSD" wurde erstellt von ch-sokrates, 5. Februar 2006 .

Schlagworte:
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 5. Februar 2006
    Hallo ,

    ich habe ein sehr merkwürdiges Problem:

    Mein selbstgeschriebener PHP http daemon (4.4.0, sockets, pcntl)
    ruft per exec() u.a. die Kommandos useradd und userdel
    auf.

    Die Ausgabe der Kommandos wird nach /dev/null umgeleitet, trotzdem
    bleiben sie als Prozess hängen und verursachen 99% CPU load.

    ps -ef zeigt dann für alle Ewigkeit:

    /usr/sbin/useradd -d /home/k463 -g k463 -p
    $1$CSLqA5CL$gN412Rmj9780NSXISV5XX/ -s /bin/bash k463
    bzw.
    userdel k463

    Bevor useradd ausgeführt wird, wird groupadd k463 ohne Fehlermeldung oder
    Hängen abgearbeitet.

    Im übrigen gibt es keine Probleme, wenn man die Befehle direkt in die
    Konsole eingibt.

    Das Problem habe ich allerdings nur unter SuSE, unter Linux Debian läuft es
    einwandfrei.
    Hat jemand einen Tipp für mich, woran das liegen könnte?

    Sperrt eventuell SuSE den Zugriff auf passwd und shadow ?

    Vielen Dank.

    Gruß
     

  2. Anzeige

  3. Videos zum Thema
Die Seite wird geladen...
Similar Threads - PHP SuSE useradd
  1. Antworten:
    2
    Aufrufe:
    1.608
  2. Antworten:
    7
    Aufrufe:
    427
  3. Antworten:
    5
    Aufrufe:
    9.275
  4. Gute PHP Template Engine

    Yuesang , 20. Februar 2017 , im Forum: Webentwicklung
    Antworten:
    4
    Aufrufe:
    3.627
  5. Antworten:
    3
    Aufrufe:
    3.641