php5 auf linux 10.0 vserver installieren

Dieses Thema im Forum "Webentwicklung" wurde erstellt von ronny130286, 12. Oktober 2006 .

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 12. Oktober 2006
    hi
    bin voll der noob in sachen linux server,
    ich habe das proble das ich auf meine linux 10.0vserver nur php4.4.0 habe, aber meine php projekte alle min php5.0.2 brauchen, wie kann ich jetzt php5 auf meinem linux server installieren.

    wäre nice wenn jemand ein gutes howtodo für mich hat

    thx schon mal vorab
     

  2. Anzeige
  3. #2 13. Oktober 2006
    AW: php5 auf linux 10.0 vserver installieren

    Ich schließe mich mal an :)
     
  4. #3 13. Oktober 2006
    AW: php5 auf linux 10.0 vserver installieren

    macht es mit xampp da habt ihr alles zusammen ;)

    hab dafür ein howto gefunden : XAMPP f

    Edit by Harley: habs mal korrigert es heißt nämlich xampp.
     
  5. #4 13. Oktober 2006
    AW: php5 auf linux 10.0 vserver installieren

    ich vermut mal du meinst SuSe 10.0 oder ??
     
  6. #5 14. Oktober 2006
    AW: php5 auf linux 10.0 vserver installieren

    ja ich meine suse
    das problem mit xampp ist das ja ne eine apache scerver auf dem vserver läuft, weil auf die idee bin ich auch schon gekommen nur kann ich dann die bestehenden webseiten nicht übernehmen
     
  7. #6 14. Oktober 2006
    AW: php5 auf linux 10.0 vserver installieren

    also das ist nicht schwer... php 5 zu installieren unter suse

    wget http://de.php.net/distributions/php-5.1.6.tar.gz

    tar -xf php-5.1.6.tar.gz

    cd php-5.1.6

    dann musst es compilieren ich kann dir mal meine configurierungs config geben aber du musst sie nicht umbedingt nehmen hau mal ne phpinfo auf deinen server und oben sollte sowas inetwa stehen das kann du nehmen oder das ich schreibe musst halt vlt anpassen.

    ./configure --prefix=/usr --datadir=/usr/share/php --bindir=/usr/bin --libdir=/usr/share --includedir=/usr/include --sysconfdir=/etc --with-_lib=lib --with-config-file-path=/etc --with-exec-dir=/usr/lib/php/bin --disable-debug --enable-bcmath --enable-calendar --enable-ctype --enable-dbase --enable-discard-path --enable-exif --enable-filepro --enable-force-cgi-redirect --enable-ftp --enable-gd-imgstrttf --enable-gd-native-ttf --enable-inline-optimization --enable-magic-quotes --enable-mbstr-enc-trans --enable-mbstring --enable-mbregex --enable-memory-limit --enable-safe-mode --enable-shmop --enable-sigchild --enable-sysvsem --enable-sysvshm --enable-track-vars --enable-trans-sid --enable-versioning --enable-wddx --enable-yp --with-bz2 --with-dom=/usr/include/libxml2 --with-ftp --with-gettext --with-jpeg-dir=/usr --with-mcrypt --with-mhash --with-mysql=/usr --with-png-dir=/usr--with-tiff-dir=/usr --with-ttf --with-freetype-dir=yes --with-zlib=yes --with-gd --with-openssl --with-curl --enable-sockets --with-apxs2=/usr/sbin/apxs2-prefork

    wenn irgentwelche fehler kommen fehlen dev packete wenn irgentwas kommt mit no bz2 oder so dann fehlt z.b das packet bz2-dev einfach unter yast nach installieren !
    dann einfach nur noch

    make

    dann

    make install



    dann gehst du in dein dein php verzeichnis das du enpackt hast und suchst die datei... php.ini-dist
    machst das -dist weg das es nur noch php.ini heißt
    kopierst diese dann nach /etc dann

    gehst du in /etc/sysconf (oder so heißt das) dort suschst du die datei apache2 öffnest diese suchst nach php4 machst das weg un schreibst php5 hin danach musst du apache2 restarten..

    /etc/init.d/apache2 restart


    und dann sollte es gehen man benötigt Linux kenntnisse !
     
  8. #7 14. Oktober 2006
  9. #8 14. Oktober 2006
    AW: php5 auf linux 10.0 vserver installieren

    Ronny adde mich mal in ICQ ich könnte dir behilflich sein wenn du möchtest ! ICQ nummer steht im Profil
     

  10. Videos zum Thema
Die Seite wird geladen...
Similar Threads - php5 linux vserver
  1. Antworten:
    2
    Aufrufe:
    1.142
  2. Antworten:
    2
    Aufrufe:
    1.618
  3. Antworten:
    7
    Aufrufe:
    439
  4. Antworten:
    1
    Aufrufe:
    230
  5. [Linux] PHP5 Update..

    zx0w , 17. Dezember 2007 , im Forum: Linux & BSD
    Antworten:
    7
    Aufrufe:
    436