Problem bei NoFrame

Dieses Thema im Forum "Webentwicklung" wurde erstellt von GaYlORd, 27. Dezember 2005 .

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 27. Dezember 2005
    Zuletzt von einem Moderator bearbeitet: 15. April 2017
    Servus!

    Ich habe ein Problem!
    Habe mir ne kleine HP in HTml geschrieben im NoFrame style...jedoch sind dder TopFrame und der MainFream etwas verschoben, obwohl ich sie beide auf center gestellt habe! Habe nen Bild angehängt...Hoffe einer weiss Rat!

    gRuß

    und Dange

    nicht heteroLord

    prob6on.jpg
    {img-src: http://img399;imageshack;us/img399/8923/prob6on;jpg}
     

  2. Anzeige
    Dealz: stark reduzierte Angebote finden.
  3. #2 27. Dezember 2005
    Hi nicht heterolORd

    Also, als erstees würde ich auf Formatierung tippen:
    z.B. anhand dieser " ".

    Was ist denn wenn du anstelle von

    frameset rows="xxx%, xxx%" cols="1*"

    es mit einem exakten Wert für den oberen und linken frame versuchst.

    Also:

    frameset rows="58px,*" cols="1*" mal als Beispiel.

    Oder versuche den Frames die Größe fest anzupassen, sprich von Pixel zu Prozent, in den meisten Fällen sind das Fehler.

    Aber mal als Frage, warum nutzt du nicht Tabellen anstatt Frames...???
     
  4. #3 27. Dezember 2005
    Hab ich gemacht babbal! ;)
    und benutze frames und tables...

    Hier der Quellcode:

    die index:

    Code:
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
    "http://www.w3.org/TR/html4/loose.dtd">
    <html>
    <head>
    <title>gl</title>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    </head>
    <frameset rows="194,*" frameborder="no" >
    <frame src="Top.htm" name="Top" scrolling="No" frameborder="0">
    <frame src="main.htm" name="main" scrolling="yes" frameborder="0">
    <!-- ###################################### NOFRAMES ############################### -->
    <noframes>
    <center>
    <table width="778" border="0">
     <tr>
     <th scope="row"><img src="Bilder/Alles_03.gif" width="778" height="151"></th>
     </tr>
     <tr>
     <th scope="row">&nbsp;</th>
     </tr>
    </table>
    <div align="center"></div>
    </center>
    </noframes>
    <!-- ###################################### NOFRAMES ############################### -->
    </frameset>
    </html>
    
    der TopFrame:

    Code:
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
    "http://www.w3.org/TR/html4/loose.dtd">
    <html>
    <head>
    <title>Unbenanntes Dokument</title>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    <style type="text/css">
    <!--
    .Stil1 {font-family: Untitled}
    -->
    </style></head>
    
    <body>
    <center>
    <TABLE BORDER="0" align="center" CELLPADDING="0" CELLSPACING="0" width="778">
     <TR>
     <TD COLSPAN=11><IMG SRC="Bilder/Alles_03.gif" WIDTH="778" HEIGHT="151" ALT=""></TD>
     </TR>
     <TR>
     <TD><IMG SRC="Bilder/Alles_05.gif" WIDTH=27 HEIGHT=26 ALT=""></TD>
     <TD><a href="main.htm" target="main"><IMG SRC="Bilder/Alles_06.gif" ALT="" WIDTH=117 HEIGHT=26 border="0"></a></TD>
     <TD><IMG SRC="Bilder/Alles_07.gif" WIDTH=15 HEIGHT=26 ALT=""></TD>
     <TD><a href="frameset.html" target="main"><IMG SRC="Bilder/Alles_08.gif" ALT="" WIDTH=115 HEIGHT=26 border="0"></a></TD>
     <TD><IMG SRC="Bilder/Alles_09.gif" WIDTH=17 HEIGHT=26 ALT=""></TD>
     <TD><IMG SRC="Bilder/Alles_10.gif" WIDTH=75 HEIGHT=26 ALT=""></TD>
     <TD><IMG SRC="Bilder/Alles_11.gif" WIDTH=10 HEIGHT=26 ALT=""></TD>
     <TD><IMG SRC="Bilder/Alles_12.gif" WIDTH=120 HEIGHT=26 ALT=""></TD>
     <TD><IMG SRC="Bilder/Alles_13.gif" WIDTH=4 HEIGHT=26 ALT=""></TD>
     <TD><IMG SRC="Bilder/Alles_14.gif" WIDTH=250 HEIGHT=26 ALT=""></TD>
     <TD><IMG SRC="Bilder/Alles_15.gif" WIDTH=28 HEIGHT=26 ALT=""></TD>
     </TR>
    </TABLE>
    </center>
    </body>
    </html>
    
    und der Main Frame:

    Code:
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
    "http://www.w3.org/TR/html4/loose.dtd">
    <html>
    <head>
    <title>Unbenanntes Dokument</title>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    <style type="text/css">
    <!--
    .Stil1 {font-family: Untitled}
    -->
    </style></head>
    
    <body>
    <center>
    <table width="778" height="600*" border="0" align="center" CELLPADDING="0" CELLSPACING="0">
     <tr>
     <th width="778" bgcolor="#324C4A" scope="row">Hans</th>
     </tr>
    </table>
    </center>
    </body>
    </html>
    
    Schonmal Danke!

    Gruß

    gl

    @babbal: hast pn bekommen?
     
  5. #4 27. Dezember 2005
    Jo, PM hab ich bekommen, danke nochmal..

    Nun zu deinem hier:

    index:
    Code:
    <th scope="row">&nbsp;</th>
    mal diese &nbsp; entfernen

    Dann in allen Frames mal diese Stücke auf feste Breiten setzen:

    als Beispiel mal 100% versuchen
    Code:
    <table width="778"
     
  6. #5 28. Dezember 2005
    Sers!

    Also, es lag an dem scrolling! (beim mainframe kommt logischerweise noch der scrollbalken dazu... :( )

    die index
    Code:
    <frame src="Top.html" name="Top" scrolling="no" frameborder="0">
    <frame src="main.php" name="main" scrolling="yes" frameborder="0">
    So, jetzt hab ich dann im Mainframe links und rechts zur tabelle noch eine Spalte hinzugefügt. Dem Linken die Breite "16" dem Rechten die breite "9*" gegeben, und die gesamte tabellenbreite auf "795*" gestellt. (die eigentliche mittlere Spalte hat immer noch 778)

    Es ist zwar alles schön untereinander, aber wenn man den Quelltext anschaut, kommt das einem etwas "beschummelt" vor!^^
    Hat wer ne alternative bzw nen eleganteren Lösungsweg?

    Hier nochmal der Quelltext der MainFrame:

    Code:
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
    "http://www.w3.org/TR/html4/loose.dtd">
    <html>
    <head>
    <title>Unbenanntes Dokument</title>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    <style type="text/css">
    <!--
    .Stil2 {color: #FFFFFF}
    -->
    </style></head>
    
    <body>
    <center>
    <table width="795*" height="600*" border="0" align="center" CELLPADDING="0" CELLSPACING="0">
     <tr>
     <th width="16">&nbsp</th>
     <th width="778" bgcolor="#324C4A">hans</th>
     <th width="9*" bgcolor="#324C4A">&nbsp;</th>
     </tr>
    </table>
    </center>
    </body>
    </html>
    
    Danke und gruß

    nicht heterolord
     
  7. #6 28. Dezember 2005
    arrgh frames hasse ich^^

    warum machst du es nicht mit php switch?

    wennde code brauchst sagen...
     
  8. #7 29. Dezember 2005
    ok, close da sich problem gekllärt hat!

    Danke an euch alle! :D


    Aber, da ich die Frames jetzt gekickt habe und es mit Tabellen machen will, gibts ein neues Problem... (ist noobproblem, aber ich bekomms einfach nicht gebacken! :( )

    Das andere Prob ist hier: HIER

    GRuß

    gl
     

  9. Videos zum Thema
Die Seite wird geladen...
Similar Threads - Problem NoFrame
  1. Antworten:
    6
    Aufrufe:
    5.450
  2. Antworten:
    4
    Aufrufe:
    8.528
  3. Antworten:
    5
    Aufrufe:
    3.717
  4. Antworten:
    0
    Aufrufe:
    3.978
  5. Antworten:
    1
    Aufrufe:
    1.852
  • Annonce

  • Annonce