ProFTPd konfigurieren

Dieses Thema im Forum "Linux & BSD" wurde erstellt von D34L3R, 15. April 2006 .

  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 15. April 2006
    Hallo Community,
    ich brauche Hilfe beim konfigurieren von ProFTPd unter Debian Sarge und das ganze soll der SSH erfolgen.
    Es wäre nett wenn mir jemand nen Link zu nem Tut geben könnte oder evtl. selber ne kleine Anleitung schreiben könnte.
    Bitte so simpel wie möglich da ich nen Linux noob bin.

    Gruss D34L3R
     

  2. Anzeige
    Dealz: stark reduzierte Angebote finden.
  3. #2 15. April 2006
    Code:
    nstallation und Konfiguration eines einfach ProFTPd Servers
    
    Also holen wir uns die Pakete.
    SuSE:
    
    yast -i proftpd
    
    Debian:
    
    apt-get install proftpd
    
    Bei Debian beantwortet man die Frage ob (x)inetd oder daemon je nach Anwendungsgebiet des Servers. Auf einem Root- oder Vserver ist der (x)inetd-Betrieb empfohlen, als Homeserver tuts Daemon eher.
    Kann nachtraeglich in der Konfiguration noch geaendert werden.
    
    Jetzt kuemmern wir uns um die Konfiguration.
    Die finden wir unter /etc/proftpd.conf (Bei Gentoo unter /etc/proftpd/proftpd.conf).
    
    Hier eine einfache Beispielkonfiguration:
    
    
    ServerName "Homeserver" #Wird beim Login angezeigt
    ServerType StandAlone #Hier wird definiert, ob der Server als Daemon oder ueber einen Dienst wie inetd gestartet wird. 
    DeferWelcome off 
    DefaultServer on 
    ShowSymlinks on #Zeige Symlinks
    
    #Optionen zur Performanceverbesserung
    IdentLookups off 
    UseReverseDNS off 
    #Diese Option sollte bei V- bzw Rootserver besser auf "on" stehen.
    AllowOverride off
    
    # Timeoutzeiten
    TimeoutNoTransfer 120
    TimeoutStalled 120
    TimeoutIdle 240
    
    ListOptions "-l"
    
    DenyFilter \*.*/
    
    #Port, auf dem der Server laufen soll.
    Port 21
    
    #Maximale Anzahl an gestarteten Instanzen des Servers und Benutzer/Gruppe, unter welcher der Server ausgefuehrt werden soll.
    MaxInstances 30
    User nobody
    Group nogroup
    
    #Chmod aller neu angelegten Dateien (777 - Umask(hier 022) = 755); Erlaubnis, Dateien zu ueberschreiben.
    Umask 022 022
    AllowOverwrite on
    
    #Sperrt den aktuellen Nutzer in seinem Homeverzeichis ein.
    DefaultRoot ~
    
    #Limitiert den Zugriff auf den Server beim Login: Alle User, die nicht Mitglied der Gruppe "ftp" sind mussen draussen bleiben, root ebenso.
    <Limit LOGIN>
    DenyGroup !ftp
    DenyUser root
    </Limit>
    
    
    In unserer Konfiguration ist der Zugriff auf alle Mitglieder der Nutzergruppe "ftp" beschraenkt. Somit muessen wir jedem User, der auf den FTP Server Zugriff haben soll, die Gruppe ftp zuweisen.
    Dazu einfach die datei /etc/group als root editieren und bei "ftp" die einzelnen Benutzer durch ein Komma getrennt einfuegen und anschliessend die Datei speichern und schliessen.
    Alternativ kann das natuerlich ueber usermod oder eine GUI erfolgen.
    
    Jetzt muessen wir unseren FTP Server noch neustarten:
    
    /etc/init.d/proftpd restart
    
    Sollte ein Fehler in der Konfiguration sein, meldet das ProFTPd bei diesem Punkt.
    is ned ganz ausgereift das tut, aber sollte reichen.
     

  4. Videos zum Thema
Die Seite wird geladen...
Similar Threads - ProFTPd konfigurieren
  1. Antworten:
    2
    Aufrufe:
    5.479
  2. ProFTPd Threads (multithreading)

    Hanskanns , 17. Oktober 2010 , im Forum: Linux & BSD
    Antworten:
    3
    Aufrufe:
    1.206
  3. ProFTPd Login Incorrect

    cable , 17. September 2010 , im Forum: Linux & BSD
    Antworten:
    5
    Aufrufe:
    996
  4. proftpd kann nicht fxpn

    Decryptor , 24. Februar 2010 , im Forum: Linux & BSD
    Antworten:
    6
    Aufrufe:
    1.239
  5. ProFtpD User anlegen

    DOWNandOUT , 23. Februar 2010 , im Forum: Linux & BSD
    Antworten:
    14
    Aufrufe:
    1.367