Ubuntu treibt mich in den Wahnsinn!

Dieses Thema im Forum "Linux & BSD" wurde erstellt von ramos, 23. Dezember 2006 .

  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 23. Dezember 2006
    Ich hab Ubuntu 6.10 so ca. schon 3 mal installiert und ich habe keine Ahnung was los ist.
    Beim ersten Mal hab ich irgendwas mit dem ATI GraKatreiber angestellt und es hat nicht mehr richtig funktioniert. Also deinstalliert und wieder neuinstalliert.

    Beim 2. Mal hat es sich bei 90% der Installation aufgehängt und hatte dann Probleme ins Win reinzukommen, aber habs schon wieder geschafft(da keine Bootpartition festgelegt war).

    Und jetzt beim 3. Mal hat die installation wunderbar geklappt, aber als ich mit dem FIrefox rumgesurft habe(so nach ca. 2 min) hat er sich aufgehängt. Hab neugestartet, firefox gestartet, und dann hat er sich aufgehängt als ich Firefox schließen wollte. Dann hab ich immer wieder neugestartet und das aufhängen ist immer früher gekommen.

    Mittlerweile hängt er sich schon beim Loginscreen auf und ich kann jetzt echt nicht verstehen wie alle behaupten, dass das System stabiler ist als Windwos?

    Ich hab nichts umgestellt, nichts umkonfiguriert(Update sofort ausgeführt), aber trotzdem ist es so unstabil.
    Weiß jemand worin der Fehler liegen kann?

    lg, Ramos
     

  2. Anzeige
    Dealz: stark reduzierte Angebote finden.
  3. #2 23. Dezember 2006
    AW: Ubuntu treibt mich in den Wahnsinn!

    ich hatte das prob auchma, lag an nem kaputten ide-kabel^^ wird aber sicher nicht das os sein, wahrscheinlicher is iwas mit der festplatte...mfg coach
     
  4. #3 23. Dezember 2006
    AW: Ubuntu treibt mich in den Wahnsinn!

    Also ich habe auch eine Zeit lang mal Ubuntu benutzt und hatte eigentlich keine Probleme. (Abgesehen davon, dass man diverse codecs und treiber "manuell" installieren muss.)

    Bist Du dir denn sicher, dass deine Hardware in Ordnung ist?
    Läuft unter Windows alles problemlos?


    Ich finde es sehr merkwürdig, dass eine frische Ubuntu-Installation beim Surfen mit FireFox Probleme aufweist. =/
    Hast Du wirklich nichts verstellt nach der Installation?
     
  5. #4 23. Dezember 2006
    AW: Ubuntu treibt mich in den Wahnsinn!

    Ich habe echt gar nichts verstellt. Das erste Mal habe ich irgendwas falsch gemacht mit dem ATI-Treiber--->neuinstallation-->aufgehängt bei 90% und jetzt beim 3. Mal installieren hats normal geklappt, hab upgedated und nichts umgestellt.
    Ich dachte es würde an Firefox liegen(dass dieser verbuggt ist oder so) und hab upgedatetd, aber das Problem besteht weiterhin.

    Das einzige was ich geändert habe war, den Mauszeiger auf den kleinen Orangenen(von Ubunt zur verfügung gestellt) gewechselt und mehr nicht.

    Ich habe eine NTFS Formatierung auf der Festplatte. Und hab nach der falschen Installation die Platte defragmentiert mit O&O Defrag, um sie wieder zu "ordnen" und dann wieder Linux draufgehaut.

    Ich kann mir nicht erklären was falsch sein könnte.

    Ich habe Ubuntu Linux auch virtuell mit (VMware) installiert(von der selben CD von der ich das Ubuntu schon 3 mal normal installiert habe,als die cd ist es nicht), habe es ein paar mal gestartet (es ist übrigens noch immer installiert), abr die virtuelle version funktioniert einwandfrei.


    Kann es vielleicht sein, dass die virtuelle und die normale Ubuntu version sich stören oder so?
    Die virtuelle habe ich nämlich zuerst installiert!

    Ich logge mich auf dem virtuellen und auf dem normalen Linux mit dem selben Namen ein, das ist das was mir gerade einfällt. KANN ES VIELLEICHT DAS SEIN ?

    lg, ramos
     
  6. #5 23. Dezember 2006
    AW: Ubuntu treibt mich in den Wahnsinn!

    also mit Vmware hängt es sicher nicht zusammen weil Vmware das virtuelle Ubuntu komplett vom richtigen OS trennt.
    Hast du schon mal ne andere Distribution versucht?
     
  7. #6 23. Dezember 2006
    AW: Ubuntu treibt mich in den Wahnsinn!

    ich würde sagen das hört sich stark nach nem Ram Problem an. Testen den doch mal mit der Ubuntu CD
     
  8. #7 23. Dezember 2006
    Ok werde jetzt einen Memorytest machen.

    Nein hat nicht daran gelegen. Memory Test --> 0 Errors.
    Hab nun Linux neuinstalliert. Alles läuft perfekt, bis auf Firefox. Auf youtube hat er sich aufgehängt und jedes mal wenn ich ihn schließe, hängt sich der PC nach 1 sek auf. Und das passiert mir schon nach dem 3 Mal installieren.

    Weiß jemand weiter ?
     
  9. #8 24. Dezember 2006
    AW: Ubuntu treibt mich in den Wahnsinn!

    Hast du denn schon mal das ausprobiert was coach geschrieben hat?
    Sämtliche Kabel und Steckverbindungen überprüft?
    Weil ich hab hier auch (K)Ubuntu 6.10 und läuft alles einwandfrei.
    Wundert mich das du so viele Probs damit hast...

    Greetz D34L3R
     
  10. #9 24. Dezember 2006
    AW: Ubuntu treibt mich in den Wahnsinn!

    Ja hab alle Kabel überprüft. Windows läuft einwandfrei, noch kein einziges Mal aufgehängt, vorallem nicht wenn ich mal Firefox schließe.
    Hab es mir vor ca. 1 Monat von ubuntu.com heruntergeladen und alle Updates ausgeführt.
    Ich verstehs echt nicht :S !?
     
  11. #10 24. Dezember 2006
    AW: Ubuntu treibt mich in den Wahnsinn!

    Es wäre hilfreicht, den Fehler anzugeben, dass bei dem Absturz entsteht. Es kommt im grunde extrem selten vor, dass tatsächlich komplettes Linux abstürzt. Meist läuft zumindest die bash - Konsole weiter, die mit strg+alt+F1 in der Regel zu erreichen ist. In diesem Fall kannst du dann die Graphikoberfläche und den x-window-server von Hand beenden. Es ist überhaupt nicht zu empfehlen, Linux einfach so zu beenden.

    Entweder hab ich dich falsch verstanden, oder du behauptest, Linux auf eine NTFS Partition installiert zu haben, was im Grunde kein Sinn macht. In der Regel kommt ja dabei EXT2-3 zum Einsatz. Da unterschiedliche OS auch auf unterschiedlichen Partitionen installiert werden, kann z. b. ein Virtuelles System, dass unter VMWare läuft, die normale installation nicht beeinflussen. Ich kenn mich zwar nicht mit VMWare aus, behaupte mal aber, dass dieses Programm zuerst unter Windows ausgeführt wurde, da Linux bei dir ja wohl nicht so gut läuft.

    Wie hast du dein System updated? Hast du dazu Synaptic benutzt oder einfach den Befehl sudo apt-get update eingetippt? Im letzten Fall hättest du einfach neuere Packet - Informationen geholt und nicht das System tatsächlich aktuallisiert. Eventuell ist die sources.list auch nicht ausgefüllt(weiß nicht, ob das immer gemacht wird oder in dem fall nur exemplarisch.) In der Konsole kann man alternative auch mit DPKG arbeiten, daher den Befehl DSELECT benutzen, um die Packetinformationen zu aktuallisieren und dann Update der Packete durchführen.

    Bei der Ubuntu Installation sollte in der Regel auch Grub BootLoader mitinstalliert werden. Ich nehme an, du hast die graphische Installationsroutine benutzt. Macht aber für den zu installierenden Inhalt wohl kein Unterschied. Hast du eine swap - Partition festlegegt? Wenn du Ubuntu hast und keine andere Version dieses Linux, sollte Gnome und xorg als Standard - Grafikserver und Benutzeroberfläche installiert sein.

    XORG bietet zwar bereits eine Unterstützung für ATI Graphikkarten und wurde bei dir offenbar auch erkannt, was bei neueren Graphikkarten nicht immer der Fall ist. Meine ATI X700Pro wurde zum Beispiel bei der Installation nicht richtig erkannt. Allerdings weiß ich nicht, welche Treiber da tatsächlich benutzt werden. Dies sieht stark nach einem Treiber Konflikt aus, daher ists hier dementsprechend empfehlenswert, ANDERE Graphiktreiber zu versuchen. Hier bieten sich mindestens 3 Möglichkeiten. Zuallererst wären da die propritären ATI Linux Treiber, Radeon Treiber für ältere Graphikchips und FGLRX Treiber, mit denen durchaus auch die neuesten Graphikkarten funktionieren. Eine 3d - Beschleinigung kann man freilich nur in den seltensten Fällen erwarten. Die Installation sollte man besser aus dem recovery mode durchführen.

    ich hab so oder so schon zu viel geschrieben, da es ohnehin klar ist, daher einfach die Links hier mit den detailierten Anweisungen zu der Installation:


    Portal › ubuntuusers.de

    http://ati.amd.com/products/catalyst/linux.html

    Startseite › Wiki › ubuntuusers.de
     
  12. #11 25. Dezember 2006
    AW: Ubuntu treibt mich in den Wahnsinn!

    Danke sehr für die ausführliche Antwort.
    Also mittlerweile habe ich es durch eine neu-installation geschafft, dass sich Linux nicht mehr aufhängt wenn ich Firefox schließe.

    Ich habe die graphische Installation benützt, und bei der Partitionsauswahl eingestellt, dass er meine C: Partition verkleinern soll und den unzugeordneten SPeicher benützen soll(sind an die 10 GB).
    Ext3 und eine Swap Partition wurden erstellt.

    Zum aktualisieren habe ich einfach die Meldung angeklickt die nach dem restart gleich nach der Installation gekommen ist und einfach alle updates installiert.

    Synaptic habe ich erst vor kurzem "herausgefunden" jedoch habe ich keienn Plan welche Dateien ich aktualisieren sollte(habe mir nur das Sprachpaket DE fuer den FIrefox installiert).

    Ich habe keine Probleme á la Systemabsturz mehr, sondern ein x-session-manager Problem.

    Nachdem ich meinen Benutzernamen und das Passwort eingebe kommt sofort die Fehlermeldung:

    Habe davor meine Win Platten gemountet, und in eine Datei(habe leider den Namen vergessen) hineingeschrieben, dass er diese bei jedem Systemstart automatisch mounten soll.
    Hat es vielleicht mit einem fehleintrag in dieser Datei zu tun?

    Habe versucht mich im agesicherten GNOME-Modus eizuloggen , jedoch erscheint hier die selbe Meldung und ich komme wieder zum Login-screen zurück.

    Der einzige Mode der mir zugänglich ist, ist der Terminal(abgesichert)-mode.

    Habe hier den Befehl: "sudo dpkg-reconfigure xserver-xorg" eingegeben um einen neuen xserver zu starten, aber hat leider nicht geklappt(habe eine ATI Radeon 9600 Pro Saphire).

    Wie komme ich nun wieder ins Ubuntu hinein ohne Anfangs diese Fehlermeldung zu erhalten?

    Sobald ich wieder hineinkomme, werde ich deinen empohlenen Befehl DSELECT benützen.

    lg, ramos
     
  13. #12 25. Dezember 2006
    AW: Ubuntu treibt mich in den Wahnsinn!

    Die datei hat fstab und wenn alle Partitionen richtig gemountet sind sollte es keine Probleme geben.
    Code:
    x-session-manager: error while loading shared libraries: libasound.so.2: cannot open shared object file. No such file or directory
    Schon mal versucht libasound bzw. die devel Packete zu installieren?
    Also ich würd dir weiterhin zu ner anderen Distribution raten weil ich absolut nicht der Fan von Ubuntu bin und du auch damit wies aussieht auf keinen grünen Ast kommst.
     
  14. #13 25. Dezember 2006
    AW: Ubuntu treibt mich in den Wahnsinn!

    Ja genau "fastab" hat die Datei geheißen. Also wird es nicht an der liegen.

    Hmm wie installiere ich das Paket libasound (bzw. Devel) wenn ich nur ins abgesicherte Terminal komme?

    Ich glaube mir fehlen hier nur die Grundkenntnisse :), dann wird es schon laufen hehe.
     
  15. #14 25. Dezember 2006
    AW: Ubuntu treibt mich in den Wahnsinn!

    installieren per konsole geht einfach per
    apt-get install libasound2
     
  16. #15 25. Dezember 2006
    AW: Ubuntu treibt mich in den Wahnsinn!

    Ok Problem gelöst in dem ich wiedermal linux neuinstalliert habe. Diesmal hab ich die partition selbst festgelet.
    Eine ext3 mit 10 GB und eine linux swap mit 2 GB. Vorher hab ich das Partitionsprogramm von Linux entscheiden lassen.

    Naja das ganze System war ziemlich stabil, bis auf firefox--->führt immer und immer wieder zum System absturz(und zwingt mich zum Neustarten).

    Keine Ahnug was los ist und hier im Forum hat mir bis her auch keiner helfen können(memorytest hat nichts gebracht).
    lG, ramos
     
  17. #16 28. Dezember 2006
    AW: Ubuntu treibt mich in den Wahnsinn!

    Falls du derartige ganz komische Problem mit der Firefox hast, versuch doch den Standard Browser. Ich hoff, du hast andere Graphiktreiber ausprobiert, denn sonst machts kein Sinn, hier nach weiten Möglichkeiten zu suchen.

    Vor allem muss man nicht gleicn das ganze System neuinstallieren, wenn du in den recovery Modus reinkomst und dich dort auch mit root Rechten einloggen kannst. Aus diesem Modus kannst du die installierte graphische Oberfläche und das jeweilige Graphikserver mit dem Befehl STARTX ausführen.

    Du kannst aus diesem Modus heraus genau so gut die XORG und GNOME bzw. KDE Packete entfernen und neu herunterladen. Am besten benutzt du dafür von der Dpkg bereitgestellte ziemlich benutzerfreundliche Packetverwaltungs-GUI DSELECT. (hast du wohl beherzigt hast) Ansonst kannst du s genau so gut mit dem apt-get remove "Packetname" Befehl das selbe machen. Es mag auch sein, dass es ausreicht, x-server neuzukonfigurieren. Die Config Datei ist etc/X11/xorg.conf. Du musst nur das entsprechende Script starten :) heißt irgend wie mit reconfigure .... müsst ich nachschauen, wie das Befehl genau lautet.

    Was die Fehlermeldung angeht, liegts entweder an der beschädigten Datei, was demnach auch durch das Löschen und neu herunterladen der Bibliothek korregiert wird oder an den Rechten. Du solltest nach der Datei mit FIND oder LOCATE suchen und die Rechte der Datei für den Benutzer, mit dem du dich in GDM einloggst, entsprechend anpassen, dass die Datei gelesen und ausgeführt werden kann. Die Schreibrechte kannst du mit dem Befehl ls -la nachschauen und mit CHMOD ändern. Lies dafür selbstverständig zuerst die MAN Pages dazu durch :) Schreibzugriff ist für die Datei, meine ich, nicht erforderlich.

    Ah ja, du musst den PC nach dem Firefox Absturz keineswegs neustarten, falls du s tust. Es genügt, die Oberfläche und x-server neuzustarten. Beenden kannst du s mit der Tastenkombination STRG+ALT+BACKSPACE. Üblicherweise wird das Ganze danach wieder neugestartet.

    Zuallerletzt kannst du ja noch andere Login Manager ausprobiere. Aber nicht vergessen, das alte Programm Packet zu löschen. Es gibt ja zumindest 3 ^^ GDM, KDM, XGM, je nach dem, was man installiert haben mag. Darüber hinaus kannst du auch unterschiedliche Benutzeroberflächen ausprobieren. Es gibt z. b. noch XFCE4. (klar KDE und GNOME).

    Falls ich mich hier wiederholt habe, macht nix ^^

    P.S.: Da du jetzt bereits mehrfach eine Neuinstallation durchgeführt hast, solltest du die entsprechende Partition NICHT schnell formatieren. Bei Schnell - Formatierung wird nur die Zuordnungstabelle gelöscht und die Daten bleiben quasi erhalten, nur dass man die so nicht lesen kann. Unter jedem System können diese Daten jedoch die neuen Datenbestände beeinschlussen.
     

  18. Videos zum Thema
Die Seite wird geladen...
Similar Threads - Ubuntu treibt mich
  1. Antworten:
    3
    Aufrufe:
    2.226
  2. Antworten:
    0
    Aufrufe:
    1.940
  3. Antworten:
    2
    Aufrufe:
    2.012
  4. Ubuntu Poppler Library

    dEm0n , 19. Mai 2014 , im Forum: Linux & BSD
    Antworten:
    0
    Aufrufe:
    1.008
  5. Antworten:
    2
    Aufrufe:
    1.535