X-server neu konfigurieren??

Dieses Thema im Forum "Linux & BSD" wurde erstellt von Dragon2k4, 13. Februar 2005 .

  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 13. Februar 2005
    WOllte ma wissen wie man xserver neu konfiguriert weil ich hab ausversehn Frameset angeschaltet und dann kommt ein display fehler...
     

  2. Anzeige
  3. #2 13. Februar 2005
    entweder mit dpkg-reconfigure xfree86 oder in /etc/X11/ die XF86Config-4 editieren
     
  4. #3 13. Februar 2005
    thx und wie deinstallier ich ?
     
  5. #4 13. Februar 2005
    apt-get remove xfree86server-common ...oder so ka wie das paket heißt
     
  6. #5 13. Februar 2005
    hab des von dir versucht da kam dass es ned vollständig installiert ist.

    wenn ich startx eingeb kommt
    Fatal server Error:
    no screens found

    X connection to :0.0 broken (exploited kill or server shoutdown)

    wenn ich startkde eingeb kommt

    $Display is not set
     
  7. #6 13. Februar 2005
    Schau mal in die /var/log/XFree.0.log, da sollte eigentlich drine stehen, woran das liegt..

    Sonst poste mal deine XF86Config hier, und schreib am besten auch dazu was du für ne Grafikkarte usw hast!
     
  8. #7 13. Februar 2005
    xfree86.0.log:
    Anhang

    XF86Config:
    Code:
    ### BEGIN DEBCONF SECTION
    # XF86Config-4 (XFree86 server configuration file) generated by dexconf, the
    # Debian X Configuration tool, using values from the debconf database.
    #
    # Edit this file with caution, and see the XF86Config-4 manual page.
    # (Type "man XF86Config-4" at the shell prompt.)
    #
    # If you want your changes to this file preserved by dexconf, only make changes
    # before the "### BEGIN DEBCONF SECTION" line above, and/or after the
    # "### END DEBCONF SECTION" line below.
    #
    # To change things within the debconf section, run the command:
    # dpkg-reconfigure xserver-xfree86
    # as root. Also see "How do I add custom sections to a dexconf-generated
    # XF86Config or XF86Config-4 file?" in /usr/share/doc/xfree86-common/FAQ.gz.
    
    Section "Files"
     FontPath "unix/:7100" # local font server
     # if the local font server has problems, we can fall back on these
     FontPath "/usr/lib/X11/fonts/misc"
     FontPath "/usr/lib/X11/fonts/cyrillic"
     FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
     FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
     FontPath "/usr/lib/X11/fonts/Type1"
     FontPath "/usr/lib/X11/fonts/Speedo"
     FontPath "/usr/lib/X11/fonts/100dpi"
     FontPath "/usr/lib/X11/fonts/75dpi"
    EndSection
    
    Section "Module"
     Load "GLcore"
     Load "bitmap"
     Load "dbe"
     Load "ddc"
     Load "dri"
     Load "extmod"
     Load "freetype"
     Load "glx"
     Load "int10"
     Load "pex5"
     Load "record"
     Load "speedo"
     Load "type1"
     Load "vbe"
     Load "xie"
    EndSection
    
    Section "InputDevice"
     Identifier "Generic Keyboard"
     Driver "keyboard"
     Option "CoreKeyboard"
     Option "XkbRules" "xfree86"
     Option "XkbModel" "pc104"
     Option "XkbLayout" "de"
     Option "XkbVariant" "de"
     Option "XkbOptions" "de"
    EndSection
    
    Section "InputDevice"
     Identifier "Configured Mouse"
     Driver "mouse"
     Option "CorePointer"
     Option "Device" "/dev/psaux"
     Option "Protocol" "PS/2"
     Option "Emulate3Buttons" "true"
     Option "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
     Identifier "Generic Mouse"
     Driver "mouse"
     Option "SendCoreEvents" "true"
     Option "Device" "/dev/input/mice"
     Option "Protocol" "ImPS/2"
     Option "Emulate3Buttons" "true"
     Option "ZAxisMapping" "4 5"
    EndSection
    
    Section "Device"
     Identifier "Generic Video Card"
     Driver "nv"
     Option "UseFBDev" "true"
    EndSection
    
    Section "Monitor"
     Identifier "Generic Monitor"
     HorizSync 28-50
     VertRefresh 43-75
     Option "DPMS"
    EndSection
    
    Section "Screen"
     Identifier "Default Screen"
     Device "Generic Video Card"
     Monitor "Generic Monitor"
     DefaultDepth 24
     SubSection "Display"
     Depth 1
     Modes "1280x1024" "1024x768" "800x600"
     EndSubSection
     SubSection "Display"
     Depth 4
     Modes "1280x1024" "1024x768" "800x600"
     EndSubSection
     SubSection "Display"
     Depth 8
     Modes "1280x1024" "1024x768" "800x600"
     EndSubSection
     SubSection "Display"
     Depth 15
     Modes "1280x1024" "1024x768" "800x600"
     EndSubSection
     SubSection "Display"
     Depth 16
     Modes "1280x1024" "1024x768" "800x600"
     EndSubSection
     SubSection "Display"
     Depth 24
     Modes "1280x1024" "1024x768" "800x600"
     EndSubSection
    EndSection
    
    Section "ServerLayout"
     Identifier "Default Layout"
     Screen "Default Screen"
     InputDevice "Generic Keyboard"
     InputDevice "Configured Mouse"
     InputDevice "Generic Mouse"
    EndSection
    
    Section "DRI"
     Mode 0666
    EndSection
    
    ### END DEBCONF SECTION
    Graka: GeForce FX5200
     
  9. #8 14. Februar 2005
    Guck mal unter
    Code:
    Section "Device"
     Identifier "Generic Video Card"
     Driver "nv"
     Option "UseFBDev" "true"
    EndSection
    und stell den Driver auf "vesa",

    mach aus
    Option "UseFBDev" "true"
    mal
    #Option "UseFBDev" "true"
    also ein # davor!

    Wenns dann funktioniert, installier dir mal die richten Linux-Treiber von nvidia, die haben dann auch opengl support usw.. Mit google solltest du ne anleitung dafür finden.. :)

    Gruss
    Kruemel
     
  10. #9 14. Februar 2005
    wie stell ich den treiber um??
     
  11. #10 14. Februar 2005
    einfach statt "nv" "vesa" reinschreiben!
     
  12. #11 14. Februar 2005
    habs grad au gemerkt ;)
    bringt aba nix wieder der gleiche fehler no screens found
     

  13. Videos zum Thema
Die Seite wird geladen...
Similar Threads - server konfigurieren
  1. Antworten:
    4
    Aufrufe:
    579
  2. Antworten:
    3
    Aufrufe:
    328
  3. PPTP Server konfigurieren

    undi , 19. Januar 2009 , im Forum: Linux & BSD
    Antworten:
    1
    Aufrufe:
    1.223
  4. Antworten:
    1
    Aufrufe:
    4.589
  5. [Server] AmxModx konfigurieren?!

    WiCk3d , 6. Dezember 2007 , im Forum: Gamer Support
    Antworten:
    10
    Aufrufe:
    688