Xampp vhosts

Dieses Thema im Forum "Netzwerk, Telefon, Internet" wurde erstellt von Almeida, 13. Februar 2008 .

Schlagworte:
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  1. #1 13. Februar 2008
    Guten Tag,
    Ich benutze xampp um eine Homepage zu hosten.
    Diese liegt in \htdocs\joomla
    Nun habe ich meinen vhost so konfiguriert:


    NameVirtualHost *:80

    <VirtualHost *:80>
    ServerName http://www.domain.tld
    ServerAlias domain.tld *.domain.tld
    DocumentRoot c:\xampp\htdocs
    </VirtualHost>

    <VirtualHost *:80>
    ServerName InterNetX - Mehr als 300 ccTLDs und gTLDs weltweit registrieren!
    DocumentRoot c:\xampp\htdocs\joomla
    </VirtualHost>

    Jetzt kann ich die Seite über den Browser aufrufen, aber es gibt gar kein Layout. Alles wirdschwarz-weiß untereinander "aufgezählt". Die Navigation auf der Seite funktioniert dann auch nicht: Objekt nicht gefunden.

    Vllt sollte ich noh sagen das es ein Windows Server 2003 ist. Weis nicht ob das wichtig ist.
    Habe ich da irgendetwas falsch eingetragen?

    mfg Lomaxxx
     

  2. Anzeige
    Dealz: stark reduzierte Angebote finden.
  3. #2 14. Februar 2008
    AW: Xampp vhosts

    hast du auch alles in dem richtigen ordner???? oder nur den html index????
     
  4. #3 14. Februar 2008
    AW: Xampp vhosts

    ich habe n ganz normale Joomla-Installation gemacht in htdocs\joomla.
    wenn ich die vhosts weglasse und über http://www.MEINEDOMAIN.de\joomla raufgehe wir ja auch alles korrekt angezeigt. eigentlich istin der vhost ja auch alles korrekt oder nicht??? aber er zeigt kein Layout an und weiterführende Links innerhalb der Seite gehen auch nicht. Nur Links die z.B. auf Google weiterleiten funktionieren.
     
  5. #4 14. Februar 2008
    AW: Xampp vhosts

    hi, erklär mir bitte dies etwas genauer, ich kenne mich bissl bei xampp aus..

    d.h du willst leute auf deine ip conecten lassen und dies deine ip in eine domain rein machen? Oder schon getan?

    Oder wenn du sich zu diesen verbindest, zeigt es dir nur eine weiße Seite, eine Fehlerseite?

    Du weisst wenn du dies direkt aus deinen PC senden willst musst du in deinem Router den Port "80" freischalten.. sonst wirds nicht gehen.
    Antw. mal meine Fragen und dann sehen wirs mal!

    cz3si0
     
  6. #5 14. Februar 2008
    AW: Xampp vhosts

    genau erklär uns mal was du schon alles gemacht hast und wie du es gemacht hast

    kenne mich auch aus mit xampp aber verstehe dich nicht so ganz

    so wie ich es verstehe...
    du gibst deinedomäne.de ein??? und kommst dann auf eine "halbaufgebaute seite"
    hast du den port 80 am router freigeschalten??? hast du einen DNS server aufgesetzt???

    was hast du alles gemacht bitte genaue angaben

    mfg hesje
     
  7. #6 14. Februar 2008
    AW: Xampp vhosts

    Also ich habe einen Windows vServer. Dort habe ich Xampp installiert. In das Verzeichniss htdocs\joomla habe ich Joomla installiert. Wenn ich jetzt mit meiner Domain so auf das Verzeichniss zugreife geht alles einwandfrei: InterNetX - Mehr als 300 ccTLDs und gTLDs weltweit registrieren!. Dann wird alles korrekt mit richtigem Layout angezeigt. Wenn ich aber nun die Einträge in der vhost mache wie oben geschrieben und dann auf InterNetX - Mehr als 300 ccTLDs und gTLDs weltweit registrieren! zugreife, wird die Seite zwar angezeigt, aber es ist kein Layout vorhanden. Ich hoffe das ist es was du wissen wolltest?

    mfg Almeida

    PS. Nehm mich mal bitte bei ICQ an, dann kann ich dir die Domain schicken.
     
  8. #7 14. Februar 2008
    AW: Xampp vhosts

    Und noch an hesje:

    ich kann ja schlecht den Port forwarden, weil ich ja auchschlecht ins Routermenü komme bei einem vServer. Oder kann ich das im Virtuozzo Power Panel machen?
    Ja die Seite wird aufgebaut und der Inhalt wird angezeigt. Aber halt unformatiert und ohne Layout und Unterseiten funktionieren gar nicht.
     
  9. #8 14. Februar 2008
    AW: Xampp vhosts

    €: aa sry warst schneller als das^^

    willst du wissen warum du kein layout sehst? DU kannst nur so gleich auf die sachen reingehen wie sie gespeichert sind z.b du hast in htdocs eine page in den ordner lol dann musst du auf http://www.deineip.de/lol gehen damit du sie sehen hast

    zu deinem problem: kopier die ganzen sachen aus den joomla ordner und füge dies in den htdocs... dann wirds gehen ODER editiere deine domain und lass sie auf xx/joomla verlinken xx=deine dns,ip, sonstiges


    p.s ich glaube ich hab mich gut ausgedrückt
     
  10. #9 14. Februar 2008
    AW: Xampp vhosts

    Also ich weis nicht, wie ich das genauer beschreiben soll.
    Ich habe meinen vServer bei United-Hoster. Dort habe ich ja auch eine Top-Level-Domain dabei gehabt.
    Fste IP habe ich da ja auch. Dann habe ich mir noch eine TLD geholt. Diese möchte ich jetzt so haben, dasss sie direkt in das Verzeichniss htdocs\joomla leitet. Das funktioniert auch mit den oben genannten EInträgen, jedoch wird die Seite ohne Layout und Formatierung angezeigt. Quasi alles untereinander.
    Lasse ich die Einträge in der vhost weg und rufe die Seite über http://www.DOMAIN.de\joomla auf funktioniert es komplett mit Layout und so weiter.

    Könnt ihr mich nicht bei ICQ adden und /oder dann auf meinen Teamspeak oder so kommen???
    Wäre echt nett,d ann kann ich das genauer erklären. Und eure Fragen direkt beantworten. Meine ICQ# ist immernoch 195468867

    mfg Dennis
     
  11. #10 14. Februar 2008
    AW: Xampp vhosts

    Das mit dem verlinken im Kunden-Panel meines Hosters habe ich probiert. Muss ja die IP eintragen da habe ich einfach mal xx\joomla eingegeben, aber das funktioniert auch nicht. Ich könnte das ja auch einfach in htdocs schmeißen, aber das Problem ist, dass da noch mehr Pages rauf sollen.
     
  12. #11 14. Februar 2008
    AW: Xampp vhosts

    Null peilung ihr leutz.

    Also, wird die Seite ordentlich ausgeliefert? (index.php, quellcode begucken)
    Ja -> wie schauen die verlinkungen der css+img aus? <base href="....?
    Nein -> Kannst du, wenn du die addresse der css datei kennst, diese aufrufen?
     
  13. #12 14. Februar 2008
    AW: Xampp vhosts

    @miffi: jo hast recht null peilung.. lese genauer es eht über joomla wenn man dies kennt weisst man wie es aufgebaut ist^^

    die page geht ja alles und so... nur die verlinkung der domänen sind falsch -_- ich kläre dies schon mit ihn in icq
     
  14. #13 14. Februar 2008
    AW: Xampp vhosts

    Vielen Dank miffi. Klappt jetzt alles einwandfrei :)

    danke danke danke
     
  15. #14 14. Februar 2008
    AW: Xampp vhosts

    Gern geschen :)
     
  16. #15 3. März 2008
    AW: Xampp vhosts

    Hallo Bin neu hier. Habe wie Almeida das gleiche Problem mit den schwarz weisse Seiten. Kann hier jemand eine genaue Anleiten hier posten?
     
  17. #16 3. März 2008
    AW: Xampp vhosts

    am besten pm an almeida :D der kann es recht gut erklären
     
  18. #17 3. März 2008
    AW: Xampp vhosts

    Möchte noch präziser sein. Mein Web läuft unter http://localhost/joomla mit xampp. Ich möchte dass es unter http://www.meinedomäne.de läuft. Zur Zeit läuft es unter http://meinedomäne.de/joomla perfekt. Da ich Anfänger bin, wäre ich euch sehr dankbar wenn ich eine step by step Anleitung hätte. Hab eine Zeitlang gegoogelt, war aber nicht fündig geworden.

    Das einzige welche ich angepasst habe, ist das index.php. Dort habe ich "xampp" mit "joomla" ersetzt. Sonst nichts.
     
  19. #18 3. März 2008
    AW: Xampp vhosts

    da brauchst du erstma eine DNS weiterleitung
    welches betriebssystem benutzt du??? am besten wäre erstmal win 2003 server
    dann stellst du deine domäne ein. dann installierst du xampp und machst eine weiterleitung auf deine dns domäne...
     
  20. #19 3. März 2008
  21. #20 3. März 2008
  22. #21 3. März 2008
    AW: Xampp vhosts

    ja genau. Werde es morgen versuchen. Melde michwieder bye
     
  23. #22 3. März 2008
    AW: Xampp vhosts

    notfalls schreibe mir mal deine icqnummer per pm dann erklär ich dir das genauer
    mache schon seit 4 jahren win 2003 server
    müssten es hin bekommen
     
  24. #23 4. März 2008
    AW: Xampp vhosts

    Hallo Hesje

    Nun, ich kriege auf einmal wie bei Almedia das Layout nicht mehr angezeigt. Es wird nur eine weisse Seite mit schwarzer Schrift dargestellt. Beim wählen der Links, kommt die Meldung, dass auf http://localhost/joomla/Link nicht zugegriffen werden kann. Sollte doch auf InterNetX - Mehr als 300 ccTLDs und gTLDs weltweit registrieren! angezeigt werden. Oder?
    Bitte beschreibe mir schritt für schritt wie das mit weiterleiten im DNS funktioniert
     
  25. #24 5. März 2008
    AW: Xampp vhosts

    So da bin ich... xD
    also geh mal in C:\Programme\xampp\apache\conf\extra\ oder dein Verzeichniss wo xampp installiert wurde. Da öffnest du die httpd-vhosts.conf. Dort trägst du folgendes ein:

    NameVirtualHost *:80

    <VirtualHost *:80>
    ServerName defaultdomain
    DocumentRoot c:\xampp\htdocs
    </VirtualHost>

    <VirtualHost *:80>
    ServerName deinedomain.de "(ohne www)"
    ServerAlias *.deinedomain.de
    DocumentRoot c:\xampp\htdocs\joomla "(oder das Verzeichnis wo deine Joomlainstallation liegt)"
    </VirtualHost>

    Dann sollte es funktionieren, es sei denn du hast die Jommlainstallation auch auf http://www.deinedomain.de/joomla gemacht. Dann musst du noch einige Änderungen in der configuration.php im Joomlaverzeichniss machen. Das kann ich dir so aber nicht erklären. Melde dich mal bei ICQ (195468867) dann machen ich dir das über Teamspeak und TeamViewer oder so.

    mfg Almeida

    PS: alles was in "" steht weglassen
     
  26. #25 5. März 2008
    AW: Xampp vhosts

    Achja und öffne in C:\WINDOWS\system32\drivers\etc\ die Datei hosts mit dem Editor und ergänze folgende Zeile:

    127.0.0.1 deinedomain.de Webhosting bei Hosting-Agency

    Wenn du das gemacht hast muss es funktionieren, ansonsten liegt es an der Configuration.php in Joomla!.

    mfg Almeida
     

  27. Videos zum Thema
Die Seite wird geladen...
Similar Threads - Xampp vhosts
  1. [SQL] (xampp) datenbank sichern

    onip , 28. August 2012 , im Forum: Webentwicklung
    Antworten:
    3
    Aufrufe:
    925
  2. Antworten:
    3
    Aufrufe:
    1.315
  3. Antworten:
    4
    Aufrufe:
    1.197
  4. Antworten:
    0
    Aufrufe:
    762
  5. Antworten:
    1
    Aufrufe:
    1.272